summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD32
-rw-r--r--hheretic.ChangeLog6
-rw-r--r--hheretic.install11
4 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d355f778e03b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = hheretic
+ pkgdesc = A Linux port of Raven Game's old shooter, Heretic (aka Hacked Heretic)
+ pkgver = 0.2.3
+ pkgrel = 1
+ url = http://hhexen.sourceforge.net/hheretic.html
+ install = hheretic.install
+ changelog = hheretic.ChangeLog
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = sdl_mixer
+ depends = glu
+ optdepends = timidity++: for midi music support
+ optdepends = heretic1-wad: data files from shareware version
+ source = http://downloads.sourceforge.net/hhexen/hheretic-0.2.3-src.tgz
+ sha256sums = ad69fbdbae75cd673b140a0f1058fd1835ce26d5859ede9e8477d5c44ec35733
+
+pkgname = hheretic
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..caee177689df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: carstene1ns <url/mail: arch carsten-teibes de>
+# Contributor: Anton Bazhenov <anton.bazhenov at gmail>
+# Contributor: Ronan Rabouin <darkbaboon@gmail.com>
+
+pkgname=hheretic
+pkgver=0.2.3
+pkgrel=1
+pkgdesc="A Linux port of Raven Game's old shooter, Heretic (aka Hacked Heretic)"
+arch=('i686' 'x86_64')
+url="http://hhexen.sourceforge.net/hheretic.html"
+license=('GPL2')
+depends=('sdl_mixer' 'glu')
+optdepends=('timidity++: for midi music support'
+ 'heretic1-wad: data files from shareware version')
+install=$pkgname.install
+changelog=$pkgname.ChangeLog
+source=("http://downloads.sourceforge.net/hhexen/$pkgname-$pkgver-src.tgz")
+sha256sums=('ad69fbdbae75cd673b140a0f1058fd1835ce26d5859ede9e8477d5c44ec35733')
+
+build() {
+ cd $pkgname-$pkgver-src
+
+ ./configure --prefix=/usr --with-audio=sdlmixer
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver-src
+
+ install -Dm755 $pkgname-gl "$pkgdir"/usr/bin/$pkgname
+ install -Dm644 README "$pkgdir"/usr/share/docs/$pkgname/README
+}
diff --git a/hheretic.ChangeLog b/hheretic.ChangeLog
new file mode 100644
index 000000000000..d2b7995828da
--- /dev/null
+++ b/hheretic.ChangeLog
@@ -0,0 +1,6 @@
+2014-01-22 carstene1ns <url/mail: arch carsten-teibes de>
+
+ * 0.2.3-1 :
+ (package adopted)
+ new upstream version
+ added doc
diff --git a/hheretic.install b/hheretic.install
new file mode 100644
index 000000000000..eee5c2b43042
--- /dev/null
+++ b/hheretic.install
@@ -0,0 +1,11 @@
+
+post_install() {
+ echo "Put your heretic(1).wad (and additional wads) in '~/.hheretic'."
+ echo "You can put custom mp3/ogg music in '~/.hheretic/music', a recreated version"
+ echo "of the original sound track is available freely here:"
+ echo "http://sycraft.org/content/audio/heretic.shtml"
+}
+
+post_upgrade() {
+ post_install
+}