summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD8
3 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 24e7b5f5c864..539db9993e19 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hhvm-git
pkgdesc = Virtual Machine, Runtime, and JIT for PHP
- pkgver = 20150816
+ pkgver = 20150820
pkgrel = 1
url = http://hhvm.com
install = hhvm.install
@@ -43,6 +43,7 @@ pkgbase = hhvm-git
source = git+https://github.com/facebook/mcrouter
source = git+https://github.com/google/re2
source = git+https://github.com/webscalesql/webscalesql-5.6
+ source = git+https://github.com/facebook/wangle
source = hhvm.tmpfile
source = hhvm@.service
source = server.ini
@@ -57,6 +58,7 @@ pkgbase = hhvm-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = c049b53f5ca7f8384d3b0a9d257018770b3a171f3b7ae8865cbb2c402a26b5e9
sha256sums = dddf4325926a41b3f1b5a41a1a42364ee463ab627f9d9b05ccf7c4660af3a51c
sha256sums = bca85e0445f3e26df65876c52e507aec8146cd31cce12c82846b55705529caed
diff --git a/.gitignore b/.gitignore
index 2427055fa4d7..dc76f139b98e 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,6 +5,7 @@
/mcrouter/
/proxygen/
/squangle/
+/wangle/
/hhvm/
/hhvm-third-party/
/clang-force-libstdc++.patch
diff --git a/PKGBUILD b/PKGBUILD
index 4339c4885238..cd9a648e8e46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_pkgname=hhvm
_github_addr=facebook/hhvm
pkgname=${_pkgname}-git
-pkgver=20150816
+pkgver=20150820
pkgrel=1
pkgdesc="Virtual Machine, Runtime, and JIT for PHP"
arch=('x86_64')
@@ -42,7 +42,8 @@ source=("git+https://github.com/$_github_addr" #1
"git+https://github.com/facebook/proxygen" #6
"git+https://github.com/facebook/mcrouter"
"git+https://github.com/google/re2"
- "git+https://github.com/webscalesql/webscalesql-5.6" #9
+ "git+https://github.com/webscalesql/webscalesql-5.6"
+ "git+https://github.com/facebook/wangle" #10
'hhvm.tmpfile'
'hhvm@.service'
'server.ini'
@@ -50,7 +51,7 @@ source=("git+https://github.com/$_github_addr" #1
'php_ini.patch')
backup=('etc/hhvm/server.ini' 'etc/hhvm/systemd-server.conf')
sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
- 'SKIP' 'SKIP' 'SKIP' 'SKIP'
+ 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
'c049b53f5ca7f8384d3b0a9d257018770b3a171f3b7ae8865cbb2c402a26b5e9'
'dddf4325926a41b3f1b5a41a1a42364ee463ab627f9d9b05ccf7c4660af3a51c'
'bca85e0445f3e26df65876c52e507aec8146cd31cce12c82846b55705529caed'
@@ -82,6 +83,7 @@ prepare() {
git config submodule.squangle/squangle.url "${srcdir}/squangle"
git config submodule.thrift/src.url "${srcdir}/fbthrift"
git config submodule.webscalesqlclient/webscalesql-5.6.url "${srcdir}/webscalesql-5.6"
+ git config submodule.wangle/src.url "${srcdir}/wangle"
git submodule update
}