summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore11
-rw-r--r--PKGBUILD58
3 files changed, 34 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be2e253100cb..3d0f15f16f52 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,16 @@
pkgbase = hidpi-daemon
pkgdesc = Daemon to manage HiDPI and LoDPI monitors on X
- pkgver = 18.04.3
- pkgrel = 1
+ pkgver = 18.04.6
+ pkgrel = 3
url = https://github.com/pop-os/hidpi-daemon
arch = any
- license = GPL
+ license = GPL2
depends = acpid
- depends = python>=3.6
- depends = python-pydbus
+ depends = libnotify
depends = python-gobject
+ depends = python-pydbus
depends = python-xlib
- depends = libnotify
- conflicts = system76-driver<17.10.32
- source = https://github.com/pop-os/hidpi-daemon/archive/18.04.3.tar.gz
- sha1sums = a2e8fbe56fdb0c992e3b20ebf7c68fd4c6158190
+ source = hidpi-daemon-18.04.6.tar.gz::https://github.com/pop-os/hidpi-daemon/archive/18.04.6.tar.gz
+ sha256sums = ecb6135128c84dd37499c642d017ee663d7e91479806b8d67d1452fb1769c370
pkgname = hidpi-daemon
-
diff --git a/.gitignore b/.gitignore
index 0cced017d91a..4dab8d6386e3 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,7 @@
-*.tar.xz
-*.tar.gz
-/pkg
-/src
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 994d0ed51c51..81db71b5561f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,47 +1,29 @@
-# Maintainer: Corey Hinshaw <coreyhinshaw(at)gmail(dot)com>
-
+# Maintainer:
+# Contributor: Mark Wagie <mark dot wagie at tutanota dot com>
+# Contributor: Corey Hinshaw <corey(at)electrickite(dot)org>
pkgname=hidpi-daemon
-pkgver=18.04.3
-pkgrel=1
+pkgver=18.04.6
+pkgrel=3
pkgdesc="Daemon to manage HiDPI and LoDPI monitors on X"
arch=('any')
url="https://github.com/pop-os/hidpi-daemon"
-license=('GPL')
-depends=(
- 'acpid'
- 'python>=3.6'
- 'python-pydbus'
- 'python-gobject'
- 'python-xlib'
- 'libnotify')
-makepdepends=(
- 'python-pyflakes')
-conflicts=('system76-driver<17.10.32')
-source=(
- "https://github.com/pop-os/${pkgname}/archive/${pkgver}.tar.gz")
-sha1sums=(
- 'a2e8fbe56fdb0c992e3b20ebf7c68fd4c6158190')
+license=('GPL2')
+depends=('acpid' 'libnotify' 'python-gobject' 'python-pydbus' 'python-xlib')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('ecb6135128c84dd37499c642d017ee663d7e91479806b8d67d1452fb1769c370')
+
+build() {
+ cd "$pkgname-$pkgver"
+ python setup.py build
+}
package() {
- cd ${srcdir}/${pkgname}-${pkgver}
-
- # Build and install base package
- python setup.py install --prefix=/usr --root=${pkgdir} --optimize=1
-
- # Install daemons and executables
- install -m755 -D hidpi-daemon ${pkgdir}/usr/lib/${pkgname}/hidpi-daemon
- install -m755 -D hidpi-notification ${pkgdir}/usr/lib/${pkgname}/hidpi-notification
-
- # Install desktop launchers
- install -m644 -D hidpi-daemon.desktop ${pkgdir}/etc/xdg/autostart/hidpi-daemon.desktop
- install -m644 -D hidpi-frontend.desktop ${pkgdir}/etc/xdg/autostart/hidpi-frontend.desktop
-
- # Install schema
- install -m644 -D com.system76.hidpi.gschema.xml ${pkgdir}/usr/share/glib-2.0/schemas/com.system76.hidpi.gschema.xml
+ cd "$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
- # Create empty /var/lib package directory
- mkdir -p ${pkgdir}/var/lib/${pkgname}
- # Clean up
- rm -rf ${pkgdir}/usr/lib/python*/site-packages/hidpidaemon/{__pycache__,tests}
+ install -Dm755 "$pkgname" hidpi-notification prime-dialog -t "$pkgdir/usr/lib/$pkgname"
+ install -Dm644 "$pkgname.desktop" hidpi-frontend.desktop -t "$pkgdir/etc/xdg/autostart"
+ install -Dm644 com.system76.hidpi.gschema.xml -t "$pkgdir/usr/share/glib-2.0/schemas"
+ install -d "$pkgdir/var/lib/$pkgname"
}