summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 22 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 396b46296931..6c53996e1c80 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,23 @@
pkgbase = higan-git
- pkgdesc = Nintendo multi-system emulator by Byuu
- pkgver = 110.r0.g483c5781
- pkgrel = 1
- url = https://higan.byuu.org/
+ pkgdesc = Multi-system emulator focused on accuracy, preservation, and configurability
+ pkgver = 115.r232.g9bf1b3314
+ pkgrel = 2
+ url = https://higan-emu.com/
arch = x86_64
- arch = i686
license = GPL3
makedepends = git
makedepends = mesa
- depends = qt5-base
depends = libpulse
- depends = gtksourceview2
+ depends = qt5-base
depends = sdl2
depends = libxv
depends = libao
depends = libgl
depends = openal
+ depends = libxrandr
provides = higan
conflicts = higan
- source = git+https://github.com/byuu/higan
+ source = git+https://github.com/higan-emu/higan.git
sha256sums = SKIP
pkgname = higan-git
-
diff --git a/PKGBUILD b/PKGBUILD
index d004adc6483c..71f1f155f4f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,22 @@
# Contributor: Salvador PardiƱas <darkfm@vera.com.uy>
pkgname=higan-git
-pkgver=110.r0.g483c5781
-pkgrel=1
-pkgdesc="Nintendo multi-system emulator by Byuu"
-arch=(x86_64 i686)
-url="https://higan.byuu.org/"
+pkgver=115.r232.g9bf1b3314
+pkgrel=2
+pkgdesc="Multi-system emulator focused on accuracy, preservation, and configurability"
+arch=(x86_64)
+url="https://higan-emu.com/"
license=(GPL3)
-depends=(qt5-base libpulse gtksourceview2 sdl2 libxv libao libgl openal)
+depends=(libpulse qt5-base sdl2 libxv libao libgl openal libxrandr)
makedepends=(git mesa)
provides=(higan)
conflicts=(higan)
-source=("git+https://github.com/byuu/higan")
+source=("git+https://github.com/higan-emu/higan.git")
sha256sums=('SKIP')
pkgver() {
cd higan
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags --exclude nightly | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
@@ -28,20 +28,20 @@ prepare() {
build() {
cd higan
- make -C higan hiro=qt5
- make -C icarus hiro=qt5
+ make -C higan-ui hiro=qt5
+ make -C icarus hiro=qt5
}
package() {
install -dm 755 "${pkgdir}"/usr/share/{higan,icarus}
- install -Dm 755 higan/higan/out/higan -t "${pkgdir}"/usr/bin/
- install -Dm 644 higan/higan/target-higan/resource/higan.desktop -t "${pkgdir}"/usr/share/applications/
- install -Dm 644 higan/higan/target-higan/resource/higan.svg -t "${pkgdir}"/usr/share/pixmaps/
+ install -Dm 755 higan/higan-ui/out/higan -t "${pkgdir}"/usr/bin/
+ install -Dm 644 higan/higan-ui/resource/higan.desktop -t "${pkgdir}"/usr/share/applications/
+ install -Dm 644 higan/higan-ui/resource/higan.png -t "${pkgdir}"/usr/share/pixmaps/
cp -dr --no-preserve='ownership' higan/higan/System "${pkgdir}"/usr/share/higan/Templates
install -Dm 755 higan/icarus/out/icarus -t "${pkgdir}"/usr/bin/
- install -Dm 644 higan/icarus/data/icarus.desktop -t "${pkgdir}"/usr/share/applications/
- install -Dm 644 higan/icarus/data/icarus.svg -t "${pkgdir}"/usr/share/pixmaps/
+ install -Dm 644 higan/icarus/resource/icarus.desktop -t "${pkgdir}"/usr/share/applications/
+ install -Dm 644 higan/icarus/resource/icarus.svg -t "${pkgdir}"/usr/share/pixmaps/
cp -dr --no-preserve='ownership' higan/icarus/Database higan/icarus/Firmware "${pkgdir}"/usr/share/icarus/
}