summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD73
-rw-r--r--allow_root.patch16
-rw-r--r--getver.patch5
4 files changed, 39 insertions, 69 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e617e8f306d..8bc30419f991 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,24 @@
pkgbase = higan-git
- pkgdesc = Multisystem emulator by Byuu
- pkgver = 105_tr1
+ pkgdesc = Nintendo multi-system emulator by Byuu
+ pkgver = 106.r221.g327a19dc
pkgrel = 1
url = https://byuu.org
arch = x86_64
arch = i686
license = GPL3
makedepends = git
+ makedepends = mesa
depends = libpulse
depends = gtksourceview2
- depends = sdl
+ depends = sdl2
depends = libxv
depends = libao
+ depends = libgl
depends = openal
provides = higan
conflicts = higan
source = git+https://gitlab.com/higan/higan.git
- source = allow_root.patch
- source = getver.patch
- md5sums = SKIP
- md5sums = 5aaffc97c4c58e95b3f1db33e8184518
- md5sums = 9fdbe0c87e2e89c0f53b96bf313cd090
+ sha256sums = SKIP
pkgname = higan-git
diff --git a/PKGBUILD b/PKGBUILD
index 5c23b75dfa3c..4950ff27b116 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,52 +1,45 @@
-# Maintainer: Salvador PardiƱas <darkfm@vera.com.uy>
+# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
+# Contributor: Salvador PardiƱas <darkfm@vera.com.uy>
+
pkgname=higan-git
-pkgver=105_tr1
+pkgver=106.r221.g327a19dc
pkgrel=1
-pkgdesc="Multisystem emulator by Byuu"
-arch=('x86_64' 'i686')
+pkgdesc="Nintendo multi-system emulator by Byuu"
+arch=(x86_64 i686)
url="https://byuu.org"
-license=('GPL3')
-groups=()
-depends=('libpulse' 'gtksourceview2' 'sdl' 'libxv' 'libao' 'openal')
-makedepends=('git')
-provides=('higan')
-conflicts=('higan')
-replaces=()
-backup=()
-options=()
-source=(
- 'git+https://gitlab.com/higan/higan.git'
- 'allow_root.patch'
- 'getver.patch')
-noextract=()
-md5sums=('SKIP'
- '5aaffc97c4c58e95b3f1db33e8184518'
- '9fdbe0c87e2e89c0f53b96bf313cd090')
-
-prepare() {
- cd $srcdir/higan
- patch -Np1 -i "${srcdir}/allow_root.patch"
- patch -Np1 -i "${srcdir}/getver.patch"
- chmod +x getver.sh
-}
+license=(GPL3)
+depends=(libpulse gtksourceview2 sdl2 libxv libao libgl openal)
+makedepends=(git mesa)
+provides=(higan)
+conflicts=(higan)
+source=("git+https://gitlab.com/higan/higan.git")
+sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/higan"
- ./getver.sh
+ cd higan
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$srcdir/higan"
- make -C icarus compiler=g++
- make -C higan compiler=g++
+ cd higan
+ make -C higan target=higan
+ make -C icarus
}
package() {
- cd "$srcdir/higan"
- mkdir -p "$pkgdir/usr/bin"
- mkdir -p "$pkgdir/usr/share/applications"
- make -C icarus prefix="$pkgdir/usr" install
- make -C higan prefix="$pkgdir/usr" install
- chmod -R 777 "$pkgdir/usr/share/higan"
- chmod -R 777 "$pkgdir/usr/share/icarus"
+ cd higan
+
+ install -Dm 755 higan/out/higan -t "${pkgdir}"/usr/bin/
+ install -Dm 644 higan/target-higan/resource/higan.desktop -t "${pkgdir}"/usr/share/applications/
+ install -Dm 644 higan/target-higan/resource/higan.png -t "${pkgdir}"/usr/share/pixmaps/
+ cp -dr --no-preserve='ownership' higan/System "${pkgdir}"/usr/share/higan
+
+ install -Dm 755 icarus/out/icarus -t "${pkgdir}"/usr/bin/
+ install -Dm 644 icarus/data/icarus.desktop -t "${pkgdir}"/usr/share/applications/
+ install -Dm 644 icarus/data/icarus.png -t "${pkgdir}"/usr/share/pixmaps/
+ install -dm 755 "${pkgdir}"/usr/share/icarus
+ cp -dr --no-preserve='ownership' icarus/Database "${pkgdir}"/usr/share/icarus/
+
+ install -dm 644 "${pkgdir}"/usr/share/higan/Video\ Shaders
+ cp -dr --no-preserve='ownership' shaders/*.shader "${pkgdir}"/usr/share/higan/Video\ Shaders
}
diff --git a/allow_root.patch b/allow_root.patch
deleted file mode 100644
index 0aec25d18a93..000000000000
--- a/allow_root.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff -Naur higan_new/higan/target-tomoko/GNUmakefile higan/higan/target-tomoko/GNUmakefile
---- higan_new/higan/target-tomoko/GNUmakefile 2017-09-24 01:13:29.844346967 -0300
-+++ higan/higan/target-tomoko/GNUmakefile 2017-09-24 01:13:06.917680171 -0300
-@@ -78,9 +78,9 @@
- endif
-
- install:
--ifeq ($(shell id -un),root)
-- $(error "make install should not be run as root")
--else ifeq ($(platform),windows)
-+#ifeq ($(shell id -un),root)
-+# $(error "make install should not be run as root")
-+ifeq ($(platform),windows)
- else ifeq ($(platform),macos)
- mkdir -p ~/Library/Application\ Support/$(name)/
- mkdir -p ~/Emulation/System/
diff --git a/getver.patch b/getver.patch
deleted file mode 100644
index 8dbb145cb0b4..000000000000
--- a/getver.patch
+++ /dev/null
@@ -1,5 +0,0 @@
-diff -Nura higan/getver.sh higan_new/getver.sh
---- higan/getver.sh 1969-12-31 21:00:00.000000000 -0300
-+++ higan_new/getver.sh 2017-06-17 15:06:09.345744032 -0300
-@@ -0,0 +1 @@
-+printf "%s\n" $(grep Version higan/emulator/emulator.hpp | head -n 1 | sed -E 's/(.*)=(.*)/\2/' | tr -d " \t\n\r\";" | sed -r 's/[(]/_/' | sed 's/[)]//')