summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
-rw-r--r--getver.patch5
3 files changed, 16 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f7c0544771df..4df2dcb27578 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = higan-git
pkgdesc = Multisystem emulator by Byuu
- pkgver = r572.1ca46090
+ pkgver = 102.26
pkgrel = 1
url = https://byuu.org
arch = x86_64
@@ -17,8 +17,10 @@ pkgbase = higan-git
conflicts = higan
source = git+https://gitlab.com/higan/higan.git
source = allow_root.patch
+ source = getver.patch
md5sums = SKIP
md5sums = 6bc32fa73fafec579fcc608feed43523
+ md5sums = 0b32b7421da621785ee29070782cfb77
pkgname = higan-git
diff --git a/PKGBUILD b/PKGBUILD
index 24bb3a54af43..724610d4d5a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Salvador PardiƱas <darkfm@vera.com.uy>
pkgname=higan-git
-pkgver=r572.1ca46090
+pkgver=102.26
pkgrel=1
pkgdesc="Multisystem emulator by Byuu"
arch=('x86_64' 'i686')
@@ -16,19 +16,23 @@ backup=()
options=()
source=(
'git+https://gitlab.com/higan/higan.git'
- 'allow_root.patch')
+ 'allow_root.patch'
+ 'getver.patch')
noextract=()
md5sums=('SKIP'
- '6bc32fa73fafec579fcc608feed43523')
+ '6bc32fa73fafec579fcc608feed43523'
+ '0b32b7421da621785ee29070782cfb77')
prepare() {
cd $srcdir/higan
patch -Np1 -i "${srcdir}/allow_root.patch"
+ patch -Np1 -i "${srcdir}/getver.patch"
+ chmod +x getver.sh
}
pkgver() {
cd "$srcdir/higan"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ ./getver.sh
}
build() {
diff --git a/getver.patch b/getver.patch
new file mode 100644
index 000000000000..1fcb17b237ba
--- /dev/null
+++ b/getver.patch
@@ -0,0 +1,5 @@
+diff -Nura higan/getver.sh higan_new/getver.sh
+--- higan/getver.sh 1969-12-31 21:00:00.000000000 -0300
++++ higan_new/getver.sh 2017-06-17 15:06:09.345744032 -0300
+@@ -0,0 +1 @@
++printf "%s\n" $(grep Version higan/emulator/emulator.hpp | head -n 1 | sed -E 's/(.*)=(.*)/\2/' | tr -d " \t\n\r\";")