summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD23
2 files changed, 6 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e9614043ab63..ccd9babcfa41 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = higan-qq
pkgdesc = A Nintendo multi-system emulator with quequotion's customizations
pkgver = 094.8d4b3cfa
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/quequotion/higan-qq
install = higan.install
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 518b64953861..aa4a42c43a2a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
pkgbase=higan-qq
pkgname=('higan-qq' 'libananke')
pkgver=094.8d4b3cfa
-pkgrel=3
+pkgrel=4
pkgdesc="A Nintendo multi-system emulator with quequotion's customizations"
arch=('i686' 'x86_64')
url=https://github.com/quequotion/higan-qq
@@ -42,15 +42,15 @@ prepare(){
#Force Super FX2 Clock (contraversial benefit)
patch -Np2 < "${srcdir}/super-fx-hax.patch"
-
- #Append user's CXXFLAGS and LDFLAGS
- sed -i "\|^flags :=| s|$| $CFLAGS|" nall/Makefile
- sed -i "\|^link :=| s|$| $LDFLAGS|" nall/Makefile
}
build(){
cd "${srcdir}/higan"
+ #Append user's CXXFLAGS and LDFLAGS
+ sed -i "\|^flags :=| s|$| $CFLAGS|" nall/Makefile
+ sed -i "\|^link :=| s|$| $LDFLAGS|" nall/Makefile
+
# libananke
make \
compiler=g++ \
@@ -58,25 +58,12 @@ build(){
-C ananke
# higan
- # Normal build (doesn't work with makepkg-optimize's pgo macro for reasons unkown)
make \
compiler=g++ \
platform=linux \
target=higan \
profile=${_profile} \
name=higan-${_profile}
-
- # Profile Guided Optimization build
- #
- # Build with profile generation
- #make pgo=instrument compiler=g++ platform=linux target=higan profile=${_profile} name=higan-${_profile}
- #
- # Run all cores and SFC special chips (except the new (famicom variant) nSide systems (Playchoice 10, VS System))
- #"${srcdir}/profilebatch" "out/higan-${_profile}" "/home/${USER}/ROMS/higan"
- #
- # Build with profile analysis
- #make clean
- #make pgo=optimize compiler=g++ platform=linux target=higan profile=${_profile} name=higan-${_profile}
}
package_libananke(){