summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO39
-rw-r--r--PKGBUILD73
-rwxr-xr-xhifi-assignment-client5
-rwxr-xr-xhifi-domain-server5
-rwxr-xr-xhifi-ice-server5
-rwxr-xr-xhifi-interface5
-rw-r--r--hifi-interface.desktop10
-rw-r--r--hifi-interface.pngbin0 -> 57454 bytes
-rw-r--r--high-fidelity-bin.install9
9 files changed, 151 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..39b48619ebbf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,39 @@
+pkgbase = high-fidelity-bin
+ pkgdesc = High Fidelity (Hifi) is an open-source software where you can create and share virtual reality (VR) experiences. Create and host your own VR world, explore other worlds and meet other users. Binaries only!
+ pkgver = 0.82.1
+ pkgrel = 1.0
+ url = https://github.com/highfidelity/hifi
+ install = high-fidelity-bin.install
+ arch = i686
+ arch = x86_64
+ license = Apache
+ depends = qt5-base>=5.10.1
+ depends = qt5-script>=5.10.1
+ depends = qt5-tools>=5.10.1
+ depends = qt5-multimedia>=5.10.1
+ depends = qt5-svg>=5.10.1
+ depends = qt5-websockets>=5.10.1
+ depends = qt5-webengine>=5.10.1
+ depends = qt5-graphicaleffects>=5.10.1
+ depends = qt5-quickcontrols>=5.10.1
+ depends = qt5-xmlpatterns>=5.10.1
+ depends = quazip
+ provides = hifi
+ conflicts = hifi
+ source = hifi-interface.desktop
+ source = hifi-interface.png
+ source = hifi-interface
+ source = hifi-assignment-client
+ source = hifi-domain-server
+ source = hifi-ice-server
+ source = git+https://github.com/Justinizer/hifi-packages.git
+ md5sums = 9199bdb8e4e32bc16b90fe0d29c4ea7a
+ md5sums = a261965ec09a8dfd93175fdabb7cafbe
+ md5sums = ff5de09932f33f6e4f4e4093a4b5e1d8
+ md5sums = 1eac79a3bc2179a4026ea1c6765fd44a
+ md5sums = ebb90bc133cb39d9d53b22fe8a954126
+ md5sums = 8405ec1a861b25e92c9640cdae8a3776
+ md5sums = SKIP
+
+pkgname = high-fidelity-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f862603a3ae0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,73 @@
+# Maintainer: Justin Jagieniak <justin@jagieniak.net>
+
+pkgname=high-fidelity-bin
+pkgver=0.82.1
+pkgrel=1.0
+pkgdesc="High Fidelity (Hifi) is an open-source software where you can create and share virtual reality (VR) experiences. Create and host your own VR world, explore other worlds and meet other users. Binaries only!"
+arch=('i686' 'x86_64')
+url="https://github.com/highfidelity/hifi"
+license=('Apache')
+install="${pkgname}.install"
+
+provides=('hifi')
+conflicts=('hifi')
+_qt5version=5.10.1
+depends=("qt5-base>=$_qt5version"
+ "qt5-script>=$_qt5version"
+ "qt5-tools>=$_qt5version"
+ "qt5-multimedia>=$_qt5version"
+ "qt5-svg>=$_qt5version"
+ "qt5-websockets>=$_qt5version"
+ "qt5-webengine>=$_qt5version"
+ "qt5-graphicaleffects>=$_qt5version"
+ "qt5-quickcontrols>=$_qt5version"
+ "qt5-xmlpatterns>=$_qt5version"
+ "quazip"
+)
+
+source=(
+ 'hifi-interface.desktop'
+ 'hifi-interface.png'
+ 'hifi-interface'
+ 'hifi-assignment-client'
+ 'hifi-domain-server'
+ 'hifi-ice-server'
+ 'git+https://github.com/Justinizer/hifi-packages.git'
+)
+
+md5sums=(
+ "9199bdb8e4e32bc16b90fe0d29c4ea7a"
+ "a261965ec09a8dfd93175fdabb7cafbe"
+ "ff5de09932f33f6e4f4e4093a4b5e1d8"
+ "1eac79a3bc2179a4026ea1c6765fd44a"
+ "ebb90bc133cb39d9d53b22fe8a954126"
+ "8405ec1a861b25e92c9640cdae8a3776"
+ "SKIP"
+)
+
+package() {
+ mkdir -p "$pkgdir/usr/share/hifi"
+ mkdir -p "$pkgdir/usr/lib"
+ mkdir -p "$pkgdir/opt"
+
+ tar -xvf "$srcdir/hifi.tar.xz" -C "$pkgdir/opt/"
+ tar -xvf "$srcdir/libraries.tar.gz" -C "$pkgdir/usr/lib/"
+
+ #copy polyvox library
+ cd "$pkgdir/usr/lib"
+ ln -s "libPolyVoxCore.so.0.2.1" "libPolyVoxCore.so.0"
+ ln -s "libPolyVoxCore.so.0.2.1" "libPolyVoxCore.so"
+
+ ln -s "libPolyVoxUtil.so.0.2.1" "libPolyVoxUtil.so.0"
+ ln -s "libPolyVoxUtil.so.0.2.1" "libPolyVoxUtil.so"
+
+ install -Dm644 "$srcdir/hifi-interface.png" "$pkgdir/usr/share/hifi/hifi-interface.png"
+ install -Dm644 "$srcdir/hifi-interface.desktop" "$pkgdir/usr/share/applications/hifi-interface.desktop"
+ install -Dm755 "$srcdir/hifi-interface" "$pkgdir/usr/bin/hifi-interface"
+
+ install -Dm755 "$srcdir/hifi-domain-server" "$pkgdir/usr/bin/hifi-domain-server"
+
+ install -Dm755 "$srcdir/hifi-ice-server" "$pkgdir/usr/bin/hifi-ice-server"
+
+ install -Dm755 "$srcdir/hifi-assignment-client" "$pkgdir/usr/bin/hifi-assignment-client"
+} \ No newline at end of file
diff --git a/hifi-assignment-client b/hifi-assignment-client
new file mode 100755
index 000000000000..f0751ce9beb0
--- /dev/null
+++ b/hifi-assignment-client
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+cd "/opt/hifi/"
+./assignment-client $*
+exit $?
diff --git a/hifi-domain-server b/hifi-domain-server
new file mode 100755
index 000000000000..ef82cfb8890d
--- /dev/null
+++ b/hifi-domain-server
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+cd "/opt/hifi/domain-server/"
+./domain-server $*
+exit $?
diff --git a/hifi-ice-server b/hifi-ice-server
new file mode 100755
index 000000000000..21d40dbb4e23
--- /dev/null
+++ b/hifi-ice-server
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+cd "/opt/hifi/"
+./ice-server $*
+exit $?
diff --git a/hifi-interface b/hifi-interface
new file mode 100755
index 000000000000..c58d3e97d1b0
--- /dev/null
+++ b/hifi-interface
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+cd "/opt/hifi/interface/"
+./interface $*
+exit $?
diff --git a/hifi-interface.desktop b/hifi-interface.desktop
new file mode 100644
index 000000000000..c02f67fd9d8c
--- /dev/null
+++ b/hifi-interface.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Type=Application
+Name=High Fidelity Interface
+Comment=Client for the decentralized, open source High Fidelity metaverse
+Exec=/opt/hifi/interface/interface
+Icon=/usr/share/hifi/hifi-interface.png
+Terminal=false
+StartupNotify=true
+Categories=Network;Game;3DGraphics
+MimeType=x-scheme-handler/hifi;
diff --git a/hifi-interface.png b/hifi-interface.png
new file mode 100644
index 000000000000..30ed775a333f
--- /dev/null
+++ b/hifi-interface.png
Binary files differ
diff --git a/high-fidelity-bin.install b/high-fidelity-bin.install
new file mode 100644
index 000000000000..98312bd89e55
--- /dev/null
+++ b/high-fidelity-bin.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo
+ echo "==> The following can now be executed:"
+ echo "==> hifi-interface: The graphical archways (client) to the boundless multiverse."
+ echo "==> hifi-assignment-client: A client for assignments. See high fidelity docs for uses."
+ echo "==> hifi-domain-server: Setup high fidelity domain server."
+ echo "==> hifi-ice-server: Set up your own server for high fidelity."
+ echo
+}