summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD25
2 files changed, 19 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5713987ce045..b4971863d1b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hikounomizu
pkgdesc = Platform-based, anime-styled fighting game
- pkgver = 0.9
+ pkgver = 1.0.1
pkgrel = 1
url = https://hikounomizu.org
arch = x86_64
@@ -9,13 +9,14 @@ pkgbase = hikounomizu
makedepends = gendesk
depends = sdl2
depends = sdl2_image
- depends = glu
+ depends = libgl
depends = freetype2
depends = openal
depends = libvorbis
- depends = tinyxml
- source = https://download.tuxfamily.org/hnm/0.9/hikounomizu-0.9-src-withdata.tar.bz2
- md5sums = 04408ed2a90471c1ead870c0b51299d0
+ depends = enet
+ depends = pugixml
+ source = https://download.tuxfamily.org/hnm/1.0.1/hikounomizu-1.0.1-src-withdata.tar.bz2
+ md5sums = d1f06d25c7baac59f5a0615e8fa9fb63
pkgname = hikounomizu
diff --git a/PKGBUILD b/PKGBUILD
index 8f5a5d9c5266..e4060866af5e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,26 @@
# Maintainer: Duncan Deveaux <duncan.at.hikounomizu.dot.org>
pkgname=hikounomizu
-pkgver=0.9
+pkgver=1.0.1
pkgrel=1
pkgdesc="Platform-based, anime-styled fighting game"
arch=('x86_64')
url="https://hikounomizu.org"
license=('custom')
-depends=('sdl2' 'sdl2_image' 'glu' 'freetype2' 'openal' 'libvorbis' 'tinyxml')
+depends=('sdl2' 'sdl2_image' 'libgl' 'freetype2' 'openal' 'libvorbis' 'enet' 'pugixml')
makedepends=('cmake>=3.13' 'gendesk')
-source=("https://download.tuxfamily.org/hnm/0.9/hikounomizu-0.9-src-withdata.tar.bz2")
-md5sums=('04408ed2a90471c1ead870c0b51299d0')
+source=("https://download.tuxfamily.org/hnm/1.0.1/hikounomizu-1.0.1-src-withdata.tar.bz2")
+md5sums=('d1f06d25c7baac59f5a0615e8fa9fb63')
prepare() {
-
- gendesk -n --pkgname "${pkgname}" --pkgdesc "${pkgdesc}" \
+
+ gendesk -n -f --pkgname "${pkgname}" --pkgdesc "${pkgdesc}" \
--name 'Hikou no mizu' --categories 'Game;ArcadeGame'
}
build() {
-
+
cmake -B build -S "${pkgname}-${pkgver}" \
-DCMAKE_BUILD_TYPE='None' \
-DCMAKE_INSTALL_PREFIX='/usr' \
@@ -29,17 +29,18 @@ build() {
}
package() {
-
+
# Install License & README
install -Dm644 "${pkgname}-${pkgver}/COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+ install -Dm644 "${pkgname}-${pkgver}/datasrc/COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/DATA_COPYING"
install -Dm644 "${pkgname}-${pkgver}/GPL" "${pkgdir}/usr/share/licenses/${pkgname}/GPL"
- install -Dm644 "${pkgname}-${pkgver}/FAL" "${pkgdir}/usr/share/licenses/${pkgname}/FAL"
- install -Dm644 "${pkgname}-${pkgver}/README" "${pkgdir}/usr/share/doc/${pkgname}/README"
-
+ install -Dm644 "${pkgname}-${pkgver}/README.md" "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+ install -Dm644 "${pkgname}-${pkgver}/CHANGES.md" "${pkgdir}/usr/share/doc/${pkgname}/CHANGES.md"
+
# Install Desktop & Icon files
install -Dm644 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
install -Dm644 "${pkgname}-${pkgver}/data/gfx/icon.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
-
+
# Install data & binary
make -C build DESTDIR="${pkgdir}" install
}