summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
2 files changed, 16 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6842ff12c49f..3d0eeb5b0982 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = himalaya-git
pkgdesc = Minimalist CLI email client, written in Rust.
- pkgver = r82.0d763a1
+ pkgver = r388.bda37ca
pkgrel = 1
url = https://github.com/soywod/himalaya
- arch = any
- license = BSD
+ arch = x86_64
+ license = MIT
makedepends = cargo
makedepends = git
depends = gcc-libs
depends = openssl
+ optdepends = notmuch-runtime: notmuch backend through cargo features
provides = himalaya
conflicts = himalaya
source = himalaya::git+https://github.com/soywod/himalaya
md5sums = SKIP
pkgname = himalaya-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 0399ae6bbc98..0bb36c32c923 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
# Maintainer: Emilio Reggi <nag@mailbox.org>
pkgname=himalaya-git
_pkgname=himalaya
-pkgver=r82.0d763a1
+pkgver=r388.bda37ca
pkgrel=1
pkgdesc="Minimalist CLI email client, written in Rust."
-arch=('any')
+arch=('x86_64')
url="https://github.com/soywod/himalaya"
-license=('BSD')
+license=('MIT')
depends=('gcc-libs' 'openssl')
makedepends=('cargo' 'git')
+optdepends=('notmuch-runtime: notmuch backend through cargo features')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
source=("${_pkgname}"::"git+${url}")
@@ -19,14 +20,20 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "$_pkgname"
+ cargo update
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
build() {
cd "$_pkgname"
- cargo build --release --locked --all-features --target-dir=target
+ RUSTUP_TOOLCHAIN=stable cargo build --release --frozen --features default --target-dir=target
}
check() {
cd "$_pkgname"
- cargo test --release --locked --target-dir=target
+ RUSTUP_TOOLCHAIN=stable cargo test --frozen --features default
}
package() {