summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD29
2 files changed, 19 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 84c8f546bef3..db30a5dcd745 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hipsparse
pkgdesc = rocSPARSE marshalling library.
- pkgver = 5.2.3
+ pkgver = 5.3.0
pkgrel = 1
url = https://hipsparse.readthedocs.io/en/latest/
arch = x86_64
@@ -10,7 +10,7 @@ pkgbase = hipsparse
makedepends = gcc-fortran
depends = hip
depends = rocsparse
- source = hipsparse-5.2.3.tar.gz::https://github.com/ROCmSoftwarePlatform/hipSPARSE/archive/rocm-5.2.3.tar.gz
- sha256sums = f70d3deff13188adc4105ef3ead53510e4b54075b9ffcfe3d3355d90d4b6eadd
+ source = hipsparse-5.3.0.tar.gz::https://github.com/ROCmSoftwarePlatform/hipSPARSE/archive/rocm-5.3.0.tar.gz
+ sha256sums = 691b32b916952ed9af008aa29f60cc190322b73cfc098bb2eda3ff68c89c7b35
pkgname = hipsparse
diff --git a/PKGBUILD b/PKGBUILD
index d253c3aaf28c..ccd573843f60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: acxz <akashpatel2008 at yahoo dot com>
pkgname=hipsparse
-pkgver=5.2.3
+pkgver=5.3.0
pkgrel=1
pkgdesc='rocSPARSE marshalling library.'
arch=('x86_64')
@@ -13,27 +13,30 @@ depends=('hip' 'rocsparse')
makedepends=('cmake' 'git' 'gcc-fortran')
_git='https://github.com/ROCmSoftwarePlatform/hipSPARSE'
source=("$pkgname-$pkgver.tar.gz::$_git/archive/rocm-$pkgver.tar.gz")
-sha256sums=('f70d3deff13188adc4105ef3ead53510e4b54075b9ffcfe3d3355d90d4b6eadd')
+sha256sums=('691b32b916952ed9af008aa29f60cc190322b73cfc098bb2eda3ff68c89c7b35')
_dirname="$(basename "$_git")-$(basename "${source[0]}" ".tar.gz")"
build() {
# -fcf-protection is not supported by HIP, see
- # https://docs.amd.com/bundle/ROCm-Compiler-Reference-Guide-v5.2/page/Appendix_A.html
- CXX=/opt/rocm/bin/hipcc \
+ # https://docs.amd.com/bundle/ROCm-Compiler-Reference-Guide-v5.3/page/Appendix_A.html
CXXFLAGS="${CXXFLAGS} -fcf-protection=none" \
HIP_PATH=/opt/rocm \
- cmake -Wno-dev -S "$_dirname" \
- -DCMAKE_INSTALL_PREFIX=/opt/rocm \
- -DBUILD_CLIENTS_SAMPLES=OFF \
- -DBUILD_CLIENTS_TESTS=OFF
- make
+ cmake \
+ -Wno-dev \
+ -B build \
+ -S "$_dirname" \
+ -DCMAKE_CXX_COMPILER=/opt/rocm/bin/hipcc \
+ -DCMAKE_INSTALL_PREFIX=/opt/rocm \
+ -DBUILD_CLIENTS_SAMPLES=OFF \
+ -DBUILD_CLIENTS_TESTS=OFF
+ cmake --build build
}
package() {
- DESTDIR="$pkgdir" make install
+ DESTDIR="$pkgdir" cmake --install build
+
+ echo "/opt/rocm/$pkgname/lib" > "$pkgname.conf"
+ install -Dm644 "$pkgname.conf" "$pkgdir/etc/ld.so.conf.d/$pkgname.conf"
- install -Dm644 /dev/stdin "$pkgdir/etc/ld.so.conf.d/hipsparse.conf" << EOF
-/opt/rocm/hipsparse/lib
-EOF
install -Dm644 "$srcdir/hipSPARSE-rocm-$pkgver/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}