summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD43
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a38c9e7293f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = hiredis-git
+ pkgdesc = Minimalistic C client library for Redis
+ pkgver = 0.14.0.r151.g3421ac3
+ pkgrel = 1
+ url = https://github.com/redis/hiredis/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ checkdepends = redis
+ makedepends = git
+ depends = glibc
+ provides = hiredis
+ conflicts = hiredis
+ options = staticlibs
+ source = git+https://github.com/redis/hiredis.git
+ sha256sums = SKIP
+
+pkgname = hiredis-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b9a275685443
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=hiredis-git
+pkgver=0.14.0.r151.g3421ac3
+pkgrel=1
+pkgdesc="Minimalistic C client library for Redis"
+arch=('i686' 'x86_64')
+url="https://github.com/redis/hiredis/"
+license=('BSD')
+depends=('glibc')
+makedepends=('git')
+checkdepends=('redis')
+provides=('hiredis')
+conflicts=('hiredis')
+options=('staticlibs')
+source=("git+https://github.com/redis/hiredis.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "hiredis"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "hiredis"
+
+ make PREFIX="/usr"
+}
+
+check() {
+ cd "hiredis"
+
+ make check
+}
+
+package() {
+ cd "hiredis"
+
+ make DESTDIR="$pkgdir" PREFIX="/usr" install
+ install -Dm644 "COPYING" -t "$pkgdir/usr/share/licenses/hiredis"
+}