summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD7
3 files changed, 16 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 092ee08a3048..c542f45c0e06 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = hoichess
pkgdesc = Xboard compatible chess engine and xiangqi (Chinese chess) engine
- pkgver = 0.16.0
+ pkgver = 0.16.1
pkgrel = 1
url = http://www.hoicher.de/hoichess
arch = i686
arch = x86_64
license = GPL2
- source = http://www.hoicher.de/hoichess/download/hoichess-0.16.0-gpl.tar.gz
- md5sums = 0bea20843c30410de1f865b6efb15b85
+ source = http://www.hoicher.de/hoichess/download/hoichess-0.16.1-gpl.tar.gz
+ md5sums = 6aa9561bb786b63c3833868a27b02493
pkgname = hoichess
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..049a1282c979
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+# Vim
+*~
+*.swp
+
+# Makepkg
+*.pkg.tar.xz
+*.tar.gz
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
index 8712498c2676..74de5dbd77c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: wangjiezhe <wangjiezhe AT yandex DOT com>
pkgname=hoichess
-pkgver=0.16.0
+pkgver=0.16.1
pkgrel=1
pkgdesc="Xboard compatible chess engine and xiangqi (Chinese chess) engine"
arch=('i686' 'x86_64')
@@ -12,13 +12,14 @@ license=('GPL2')
url="http://www.hoicher.de/hoichess"
depends=()
source=(${url}/download/${pkgname}-${pkgver}-gpl.tar.gz)
-md5sums=('0bea20843c30410de1f865b6efb15b85')
+md5sums=('6aa9561bb786b63c3833868a27b02493')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
sed -i 's/games$/bin/' Makefile
sed -i 's/CXXFLAGS\ =/CXXFLAGS\ +=/' src/Makefile
- sh "book/download-gnuchess-book"
+ cd "book"
+ sh "download-gnuchess-book"
}
build() {