summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD22
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5f142dd60446
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = home-assistant-circadian_lighting
+ pkgdesc = Custom component for Home Assistant, to adjust lights based on daylight
+ pkgver = 1.0.13
+ pkgrel = 1
+ url = https://github.com/claytonjn/hass-circadian_lighting
+ arch = any
+ license = Apache-2.0
+ depends = home-assistant
+ source = home-assistant-circadian_lighting-1.0.13::https://github.com/claytonjn/hass-circadian_lighting/archive/1.0.13.tar.gz
+ sha512sums = c89885f39d16e05ee6c77769f7c759d069a2a3e72e16f78c56fdd8e370c0c3447f84b220e1e49649c5894c9df86d1a5e6b2b62cd43d5d7892b72630423d3c00f
+
+pkgname = home-assistant-circadian_lighting
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6ff79861192c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
+
+_pkgname=hass-circadian_lighting
+pkgname=home-assistant-circadian_lighting
+pkgver=1.0.13
+pkgrel=1
+pkgdesc="Custom component for Home Assistant, to adjust lights based on daylight"
+arch=(any)
+url="https://github.com/claytonjn/hass-circadian_lighting"
+license=("Apache-2.0")
+depends=("home-assistant")
+source=("$pkgname-$pkgver::https://github.com/claytonjn/hass-circadian_lighting/archive/${pkgver}.tar.gz")
+sha512sums=('c89885f39d16e05ee6c77769f7c759d069a2a3e72e16f78c56fdd8e370c0c3447f84b220e1e49649c5894c9df86d1a5e6b2b62cd43d5d7892b72630423d3c00f')
+
+
+package() {
+ cd "$_pkgname-$pkgver"
+
+ find "custom_components" -type f -exec install -vDm 644 {} "${pkgdir}/var/lib/hass/"{} \;
+
+ install -Dm 644 "README.md" "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+}