summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
-rw-r--r--config2
-rw-r--r--hostapd@.service10
4 files changed, 20 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9017b38c1458..a6724260be3c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hostapd-noscan
pkgdesc = IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator (with "noscan" patch)
pkgver = 2.10
- pkgrel = 1
+ pkgrel = 4
url = https://w1.fi/hostapd/
arch = i686
arch = x86_64
@@ -25,10 +25,12 @@ pkgbase = hostapd-noscan
source = https://w1.fi/releases/hostapd-2.10.tar.gz
source = config
source = hostapd.service
+ source = hostapd@.service
source = noscan.patch
sha256sums = 206e7c799b678572c2e3d12030238784bc4a9f82323b0156b4c9466f1498915d
- sha256sums = d0bbbfec38e338938910b09704ab986f3615b15ed2e0832d368ce3e9b94e3c51
+ sha256sums = 60f2d0dd943f78a90662f894ec0a97a0fc95cfbac1c2628da64f1da83e344f0b
sha256sums = 989bc6855f44c0b360e3d4cd4a146c35b7c12f8a0ced627b4b033f58edcade8e
+ sha256sums = 80d82f6515df1061d2fad4a39a1efb9c4ef9828837441d556593a3f852242a95
sha256sums = b449b6158466903c06c0ed0f19aef506351021f8b332eabc03467e9928258128
pkgname = hostapd-noscan
diff --git a/PKGBUILD b/PKGBUILD
index 7d021b90c681..93009d078e54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=hostapd-noscan
_pkgname=hostapd
pkgver=2.10
-pkgrel=1
+pkgrel=4
pkgdesc="IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator (with \"noscan\" patch)"
arch=(i686 x86_64 armv6h armv7h aarch64)
url="https://w1.fi/hostapd/"
@@ -17,10 +17,12 @@ backup=("etc/${_pkgname}/${_pkgname}."{accept,conf,deny,eap_user,radius_clients,
source=("https://w1.fi/releases/${_pkgname}-${pkgver}.tar.gz"
"config"
"hostapd.service"
+ "hostapd@.service"
"noscan.patch")
sha256sums=('206e7c799b678572c2e3d12030238784bc4a9f82323b0156b4c9466f1498915d'
- 'd0bbbfec38e338938910b09704ab986f3615b15ed2e0832d368ce3e9b94e3c51'
+ '60f2d0dd943f78a90662f894ec0a97a0fc95cfbac1c2628da64f1da83e344f0b'
'989bc6855f44c0b360e3d4cd4a146c35b7c12f8a0ced627b4b033f58edcade8e'
+ '80d82f6515df1061d2fad4a39a1efb9c4ef9828837441d556593a3f852242a95'
'b449b6158466903c06c0ed0f19aef506351021f8b332eabc03467e9928258128')
prepare() {
@@ -59,6 +61,7 @@ package() {
# systemd service
install -vDm 644 "../${_pkgname}.service" -t "${pkgdir}/usr/lib/systemd/system/"
+ install -vDm 644 "../${_pkgname}@.service" -t "${pkgdir}/usr/lib/systemd/system/"
# license
install -vDm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${_pkgname}/"
diff --git a/config b/config
index be9476fb2225..c5f866a04f61 100644
--- a/config
+++ b/config
@@ -159,7 +159,7 @@ CONFIG_IEEE80211AC=y
# Note: This is experimental and work in progress. The definitions are still
# subject to change and this should not be expected to interoperate with the
# final IEEE 802.11ax version.
-#CONFIG_IEEE80211AX=y
+CONFIG_IEEE80211AX=y
# Remove debugging code that is printing out debug messages to stdout.
# This can be used to reduce the size of the hostapd considerably if debugging
diff --git a/hostapd@.service b/hostapd@.service
new file mode 100644
index 000000000000..3b0f3ad48f40
--- /dev/null
+++ b/hostapd@.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Hostapd IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator
+After=network.target
+
+[Service]
+ExecStart=/usr/bin/hostapd /etc/hostapd/%i.conf
+ExecReload=/bin/kill -HUP $MAINPID
+
+[Install]
+WantedBy=multi-user.target