summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD2
-rw-r--r--config98
3 files changed, 3 insertions, 100 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec478d8a0cef..8ed61d4cda3a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,7 +6,8 @@ pkgbase = hostapd-rtl
install = hostapd.install
arch = i686
arch = x86_64
- arch = armv7
+ arch = armv7h
+ arch = armv6l
license = custom
depends = openssl
depends = libnl
diff --git a/PKGBUILD b/PKGBUILD
index be049f45170e..99dba2f94e3b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgname=hostapd-rtl
pkgver=2.4
pkgrel=1
pkgdesc="IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator"
-arch=('i686' 'x86_64' 'armv7')
+arch=('i686' 'x86_64' 'armv7h' 'armv6l')
url="http://w1.fi/hostapd/"
license=('custom')
depends=('openssl' 'libnl')
diff --git a/config b/config
deleted file mode 100644
index 0fcad7af4f91..000000000000
--- a/config
+++ /dev/null
@@ -1,98 +0,0 @@
-# Example hostapd build time configuration
-#
-# This file lists the configuration options that are used when building the
-# hostapd binary. All lines starting with # are ignored. Configuration option
-# lines must be commented out complete, if they are not to be included, i.e.,
-# just setting VARIABLE=n is not disabling that variable.
-#
-# This file is included in Makefile, so variables like CFLAGS and LIBS can also
-# be modified from here. In most cass, these lines should use += in order not
-# to override previous values of the variables.
-
-# Driver interface for Host AP driver
-CONFIG_DRIVER_HOSTAP=y
-
-# Driver interface for wired authenticator
-CONFIG_DRIVER_WIRED=y
-
-# Driver interface for Prism54 driver
-CONFIG_DRIVER_PRISM54=y
-
-# IEEE 802.11F/IAPP
-CONFIG_IAPP=y
-
-# WPA2/IEEE 802.11i RSN pre-authentication
-CONFIG_RSN_PREAUTH=y
-
-# PeerKey handshake for Station to Station Link (IEEE 802.11e DLS)
-CONFIG_PEERKEY=y
-
-# IEEE 802.11w (management frame protection)
-# This version is an experimental implementation based on IEEE 802.11w/D1.0
-# draft and is subject to change since the standard has not yet been finalized.
-# Driver support is also needed for IEEE 802.11w.
-CONFIG_IEEE80211W=y
-
-# Integrated EAP server
-CONFIG_EAP=y
-
-# EAP-MD5 for the integrated EAP server
-CONFIG_EAP_MD5=y
-
-# EAP-TLS for the integrated EAP server
-CONFIG_EAP_TLS=y
-
-# EAP-MSCHAPv2 for the integrated EAP server
-CONFIG_EAP_MSCHAPV2=y
-
-# EAP-PEAP for the integrated EAP server
-CONFIG_EAP_PEAP=y
-
-# EAP-GTC for the integrated EAP server
-CONFIG_EAP_GTC=y
-
-# EAP-TTLS for the integrated EAP server
-CONFIG_EAP_TTLS=y
-
-# EAP-SIM for the integrated EAP server
-CONFIG_EAP_SIM=y
-
-# EAP-AKA for the integrated EAP server
-CONFIG_EAP_AKA=y
-
-# EAP-PAX for the integrated EAP server
-CONFIG_EAP_PAX=y
-
-# EAP-PSK for the integrated EAP server (this is _not_ needed for WPA-PSK)
-CONFIG_EAP_PSK=y
-
-# EAP-SAKE for the integrated EAP server
-CONFIG_EAP_SAKE=y
-
-# EAP-GPSK for the integrated EAP server
-CONFIG_EAP_GPSK=y
-# Include support for optional SHA256 cipher suite in EAP-GPSK
-CONFIG_EAP_GPSK_SHA256=y
-
-# PKCS#12 (PFX) support (used to read private key and certificate file from
-# a file that usually has extension .p12 or .pfx)
-CONFIG_PKCS12=y
-
-# RADIUS authentication server. This provides access to the integrated EAP
-# server from external hosts using RADIUS.
-CONFIG_RADIUS_SERVER=y
-
-# Build IPv6 support for RADIUS operations
-CONFIG_IPV6=y
-
-CONFIG_DRIVER_NL80211=y
-
-CONFIG_IEEE80211N=y
-
-CONFIG_LIBNL32=y
-
-CONFIG_ACS=y
-
-CONFIG_IEEE80211AC=y
-
-CONFIG_OPENVSWITCH=y