aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
-rw-r--r--README47
3 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c233e1e7c896
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = hotp-totp-php
+ pkgdesc = PHP tool to create one-time passwords via HOTP, TOTP, OCRA, OAuth 1.0a 2.0; rfc4226, 6238, 6287, 5849, 6749
+ pkgver = 4.4.1
+ pkgrel = 1
+ url = https://sourceforge.net/projects/hotp-totp-php
+ arch = any
+ license = Apache
+ depends = php
+ source = https://sourceforge.net/projects/hotp-totp-php/files/v4.4.1/HOTP-TOTP.PHP.v4.4.1.zip
+ source = README
+ sha512sums = 264d1aceb6151eb8ebce2a10ad32d6d41101954ef34404feba8b3171b92385fe660926ffab93d01fe47b39c99f4dee422adaad8bab64aedef276d787cfffb5b6
+ sha512sums = 4e5cea1b82e32a011bdf6f9e13349a26e2caeb4bf70e1dfd3440e53e36949b55f3d354c8c24e5c507eac3fa3b6135d7363d110de26369125d44a491416673d33
+
+pkgname = hotp-totp-php
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..212c5cc12791
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Mcnster <me@mcnster.com>
+pkgname=hotp-totp-php
+_prjname=HOTP-TOTP.PHP
+pkgver=4.4.1
+pkgrel=1
+pkgdesc="PHP tool to create one-time passwords via HOTP, TOTP, OCRA, OAuth 1.0a 2.0; rfc4226, 6238, 6287, 5849, 6749"
+arch=('any')
+url="https://sourceforge.net/projects/hotp-totp-php"
+license=('Apache')
+depends=('php')
+makedepends=()
+source=("https://sourceforge.net/projects/$pkgname/files/v$pkgver/$_prjname.v$pkgver.zip"
+"README")
+sha512sums=('264d1aceb6151eb8ebce2a10ad32d6d41101954ef34404feba8b3171b92385fe660926ffab93d01fe47b39c99f4dee422adaad8bab64aedef276d787cfffb5b6'
+'4e5cea1b82e32a011bdf6f9e13349a26e2caeb4bf70e1dfd3440e53e36949b55f3d354c8c24e5c507eac3fa3b6135d7363d110de26369125d44a491416673d33')
+validpgpkeys=()
+
+package() {
+ mkdir -p $pkgdir/usr/share/$pkgname
+ cp README $pkgdir/usr/share/$pkgname
+ cd $srcdir
+ cp index.php $pkgdir/usr/share/$pkgname
+ cp index_oauth2.php $pkgdir/usr/share/$pkgname
+}
diff --git a/README b/README
new file mode 100644
index 000000000000..5135157eb152
--- /dev/null
+++ b/README
@@ -0,0 +1,47 @@
+HOTP-TOTP.PHP v4.4.1
+====================
+
+Introduction
+------------
+
+This project consists of two PHP files:
+
+ * index.php
+ * index_oauth.php
+
+These files generate HTML forms that can be used to generate one-time password
+values based on:
+
+ * HOTP: An HMAC-Based One-Time Password Algorithm (rfc4226)
+ * TOTP: Time-Based One-Time Password Algorithm (rfc6238)
+ * OCRA: OATH Challenge-Response Algorithm (rfc6287)
+
+Further, it also supports the client side of the OAuth protocols (1.0a
+and 2.0).
+
+
+How to Use
+----------
+
+1. Copy `index.php' and `index_oauth.php' to a location readable by a
+PHP-aware web server, such as ~/public_html in your home directory
+(assuming `User Home Directories' are enabled).
+
+
+2. Open `index.php' in your web-browser.
+
+3. Read the instructions on the generated page, choose the appropriate
+algorithm and click "NOW!"
+
+
+Notes
+-----
+
+A newer GSMA-side Mobile Connect version has been published since this
+version of HOTP-TOTP.PHP was released.
+
+The next release of this software will include new GSM-specific OpenID
+Connect code.
+
+Thank you!
+