summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD45
-rw-r--r--qt511.patch13
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..39e326773f55
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = hotshots-git
+ pkgdesc = Screenshot tool with some editing features.
+ pkgver = 77181c5
+ pkgrel = 1
+ url = http://thehive.xbee.net
+ arch = x86_64
+ arch = i686
+ license = GPL2
+ makedepends = cmake
+ depends = qt5-base
+ depends = qt5-x11extras
+ depends = shared-mime-info
+ source = git://github.com/obiwankennedy/HotShots.git
+ source = qt511.patch
+ sha256sums = SKIP
+ sha256sums = f25246aa323ed5a190f99d23eb934fcd9ba9e11e5513fd4a5c9f507d6bd6e011
+
+pkgname = hotshots-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..855410644bfa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+pkgname=hotshots-git
+pkgver=77181c5
+pkgrel=1
+pkgdesc="Screenshot tool with some editing features."
+url="http://thehive.xbee.net"
+arch=('x86_64' 'i686')
+license=('GPL2')
+depends=('qt5-base' 'qt5-x11extras' 'shared-mime-info')
+makedepends=('cmake')
+source=('git://github.com/obiwankennedy/HotShots.git'
+ 'qt511.patch')
+sha256sums=('SKIP'
+ 'f25246aa323ed5a190f99d23eb934fcd9ba9e11e5513fd4a5c9f507d6bd6e011')
+
+prepare() {
+ cd "${srcdir}/HotShots"
+ patch -p1 -i ../qt511.patch
+}
+
+build() {
+ cd "${srcdir}/HotShots/"
+ sed -i "s/\/usr\/local/\/usr/g" hotshots.desktop
+ qmake
+ make
+}
+
+package() {
+ install -Dm755 "${srcdir}/HotShots/release/hotshots" "${pkgdir}/usr/bin/hotshots"
+ install -Dm755 "${srcdir}/HotShots/hotshots.desktop" "${pkgdir}/usr/share/applications/hotshots.desktop"
+
+ for file in `ls "${srcdir}/HotShots/lang/"`; do
+ install -Dm644 "${srcdir}/HotShots/lang/$file" "${pkgdir}/usr/share/hotshots/locale/$file"
+ done
+
+ install -Dm644 "${srcdir}/HotShots/AUTHORS.txt" "${pkgdir}/usr/share/hotshots/AUTHORS.txt"
+ install -Dm644 "${srcdir}/HotShots/Changelog.txt" "${pkgdir}/usr/share/hotshots/Changelog.txt"
+ install -Dm644 "${srcdir}/HotShots/CREDITS.txt" "${pkgdir}/usr/share/hotshots/CREDITS.txt"
+ install -Dm644 "${srcdir}/HotShots/README.txt" "${pkgdir}/usr/share/hotshots/README.txt"
+ install -Dm644 "${srcdir}/HotShots/res/hotshots.png" "${pkgdir}/usr/share/pixmaps/hotshots.png"
+ install -Dm644 "${srcdir}/HotShots/hotshots.1.gz" "${pkgdir}/usr/share/man/man1/hotshots.1.gz"
+}
+
+post_install() {
+ update-desktop-database -q
+} \ No newline at end of file
diff --git a/qt511.patch b/qt511.patch
new file mode 100644
index 000000000000..46b77f6d8e87
--- /dev/null
+++ b/qt511.patch
@@ -0,0 +1,13 @@
+diff -cr a/src/AboutDialog.h b/src/AboutDialog.h
+*** a/src/AboutDialog.h 2018-08-21 20:19:11.097055938 +0300
+--- b/src/AboutDialog.h 2018-08-21 20:06:15.323546858 +0300
+***************
+*** 22,27 ****
+--- 22,28 ----
+ #define _DIALOGABOUT_H_
+
+ #include <QDialog>
++ #include <QAction>
+ #include "ui_AboutDialog.h"
+
+ class QListWidgetItem;