summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--01-package-path.patch16
-rw-r--r--02-executable.patch14
-rw-r--r--PKGBUILD29
-rw-r--r--hp15c_runner.sh4
5 files changed, 21 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8fdb96bb6c4c..8cdea2ea45df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,11 +9,11 @@ pkgbase = hp15c
depends = tk
source = hp15c-4.0.0.zip::https://drive.google.com/uc?export=download&id=1ewFXi6PPRsiPJESUq5A2Gp83NYSYVYKr
source = 01-package-path.patch
- source = 02-executable.patch
+ source = hp15c_runner.sh
source = hp15c.desktop
md5sums = c90cc630d9e5bdf70912f8cd754cc2cc
- md5sums = dc2c7e620a146bb718f05060393080ac
- md5sums = d18b93bc1077430fed1e3563042a69ea
+ md5sums = 1cce408ad1c6c8458681690e96a02508
+ md5sums = 33588adff38833aa1a2957457d4701b3
md5sums = bab776009feb1db971b92649c839ff1f
pkgname = hp15c
diff --git a/01-package-path.patch b/01-package-path.patch
index 9b7a4f554f58..03e17e047070 100644
--- a/01-package-path.patch
+++ b/01-package-path.patch
@@ -13,14 +13,6 @@ index 50238bb..209392b
set APPDATA(locale) [mclocale]
# Load language according to current locale
-@@ -487,6 +487,7 @@ if {![file exists $dnam]} {
- set dnam "$APPDATA(basedir)/images"
- }
-
-+
- foreach img {PrefIconSimulator.gif PrefIconSystem.gif PrefIconFiles.gif
- PrefIconDM15CC.gif PrefIconFonts.gif PrefIconHelp.gif PrevIconDev.gif
- dispframe.gif HP-15C-logo-256.png HP-15C-logo-512.png} {
@@ -3252,14 +3253,7 @@ proc help { topic } {
switch $topic {
@@ -37,10 +29,4 @@ index 50238bb..209392b
}
prgm {
set helpfile "$HP15(prgmdir)/$HP15(prgmname).htm"
-@@ -9507,4 +9501,4 @@ option add *tearOff 0
- # ------------------------------------------------------------------------------
- # And now let the window manager show the interface in all it's beauty...
- wm deiconify .
--#set curdisp " XP-15C"
-\ No newline at end of file
-+#set curdisp " XP-15C"
+---
diff --git a/02-executable.patch b/02-executable.patch
deleted file mode 100644
index bbdd36a4bf87..000000000000
--- a/02-executable.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff --git a/HP-15C.tcl b/HP-15C.tcl
-index 209392b..2990af9 100755
---- a/HP-15C.tcl
-+++ b/HP-15C.tcl
-@@ -1,3 +1,9 @@
-+#!/bin/sh
-+# the next line restarts using wish \
-+TCLLIBPATH="/usr/lib/hp15c/lib" exec wish "$0" "$@"
-+
-+# ----------------- Make script executable, see https://www.tcl.tk/man/tcl8.3/UserCmd/wish.htm
-+
- # ------------------------------------------------------------------------------
- #
- # H E W L E T T - P A C K A R D 15C
diff --git a/PKGBUILD b/PKGBUILD
index 5cddbd930c77..f394c7883e65 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,21 +12,20 @@ depends=('tcl' 'tk')
source=(
"$pkgname-$pkgver.zip::https://drive.google.com/uc?export=download&id=1ewFXi6PPRsiPJESUq5A2Gp83NYSYVYKr"
"01-package-path.patch"
- "02-executable.patch"
+ "hp15c_runner.sh"
"hp15c.desktop"
)
md5sums=('c90cc630d9e5bdf70912f8cd754cc2cc'
- 'dc2c7e620a146bb718f05060393080ac'
- 'd18b93bc1077430fed1e3563042a69ea'
+ '1cce408ad1c6c8458681690e96a02508'
+ '33588adff38833aa1a2957457d4701b3'
'bab776009feb1db971b92649c839ff1f')
prepare() {
- # patch
- for file in $srcdir/*.patch; do
- patch -p1 -i $file
- done
- #Extract icons
+ # patch location of files to match Arch standards
+ patch -p1 -i "$srcdir/01-package-path.patch"
+
+ # extract icons
unzip icons/HP-15C-logo.zip -d $srcdir/icon_extract
}
@@ -42,19 +41,17 @@ package() {
cp -r css icons lib msgs images -t "$pkgdir/usr/lib/$pkgname/"
install -Dm644 HP-15C_Simulator_Font.ttf -t "$pkgdir/usr/share/fonts/"
- # set up launch script
- install -m 755 HP-15C.tcl -t "$pkgdir/usr/lib/$pkgname/"
- mkdir -p "$pkgdir/usr/bin"
- ln -s "/usr/lib/$pkgname/HP-15C.tcl" "$pkgdir/usr/bin/hp15c"
+ # runs script in proper directory
+ cp HP-15C.tcl -t "$pkgdir/usr/lib/$pkgname/"
+ install -D "$srcdir/hp15c_runner.sh" "$pkgdir/usr/bin/hp15c"
- # Install Desktop Entry
+ # install desktop entry
install -D hp15c.desktop "$pkgdir/usr/share/applications/hp15c.desktop"
- # Install icon
+ # install icon
for i in 22 32 48 256 512 ; do
- install -D "icon_extract/HP-15C-logo-$i"'x'"$i.png" "$pkgdir/usr/share/icons/hicolor/$i"'x'"$i/apps/hp15c.png"
+ install -D "icon_extract/HP-15C-logo-${i}x${i}.png" "$pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/hp15c.png"
done
-
}
# vim:set ts=4 sw=4 ft=sh et:
diff --git a/hp15c_runner.sh b/hp15c_runner.sh
new file mode 100644
index 000000000000..7d4500b66f49
--- /dev/null
+++ b/hp15c_runner.sh
@@ -0,0 +1,4 @@
+#!/bin/sh
+# runs HP-15C tcl script in proper directory
+cd /usr/lib/hp15c
+/usr/bin/wish HP-15C.tcl "$@"