summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD23
2 files changed, 15 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b5d4900ee499..195fc8fd255a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = hpfall-git
pkgdesc = Disk protection for HP machines.
pkgver = r5.be24a8b
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/srijan/hpfall.git
arch = x86_64
arch = i686
+ license = GPL2
makedepends = git
- source = hpfall-git::git://github.com/srijan/hpfall.git
+ depends = glibc
+ source = git+https://github.com/srijan/hpfall.git
source = log_to_syslog.patch
source = hpfall.service
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 4c10d4e9ea7d..0d926aefb838 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,35 +2,34 @@
pkgname=hpfall-git
pkgver=r5.be24a8b
-pkgrel=1
+pkgrel=2
pkgdesc="Disk protection for HP machines."
arch=('x86_64' 'i686')
-url_name="github.com/srijan/hpfall.git"
-url="https://"${url_name}
-License=('GPL')
-depends=()
+url="https://github.com/srijan/hpfall.git"
+license=('GPL2')
+depends=('glibc')
makedepends=('git')
md5sums=('SKIP' 3a6a193021fe5f3078f97b8c2a4c8538 ac946477d1996e68fa63792829fd8a97)
-source=("${pkgname}"::"git://"${url_name} 'log_to_syslog.patch' 'hpfall.service')
+source=("git+${url}" 'log_to_syslog.patch' 'hpfall.service')
pkgver() {
- cd "$srcdir/${pkgname}"
+ cd "${srcdir}/${pkgname%-git}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare(){
- cd "$srcdir/${pkgname}"
+ cd "${srcdir}/${pkgname%-git}"
patch -R hpfall.c < ../log_to_syslog.patch
}
build() {
- cd "$srcdir"/${pkgname}
+ cd "${srcdir}/${pkgname%-git}"
make
}
package() {
- install -Dm755 ${pkgname}/hpfall $pkgdir/usr/bin/hpfall
- install -Dm755 ${pkgname}/../hpfall.service $pkgdir/usr/lib/systemd/system/hpfall.service
+ install -Dm755 "${pkgname%-git}/hpfall" "${pkgdir}/usr/bin/hpfall"
+ install -Dm644 hpfall.service "${pkgdir}/usr/lib/systemd/system/hpfall.service"
-} \ No newline at end of file
+}