summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD21
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d25a29ddc6ed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = hqplayer
+ pkgdesc = The high-end upsampling multichannel software HD-audio player
+ pkgver = 4.0.0
+ pkgrel = 1
+ url = http://www.signalyst.com/consumer.html
+ arch = x86_64
+ license = custom
+ depends = glibc
+ depends = gcc-libs
+ depends = libx11
+ depends = qt5-base
+ depends = qt5-script
+ depends = qt5-quickcontrols
+ depends = qt5-quickcontrols2
+ depends = qt5-svg
+ depends = qt5-declarative
+ depends = qt5-graphicaleffects
+ depends = libmicrohttpd
+ depends = alsa-lib
+ depends = flac
+ optdepends = evince: hqplayer manual reading
+ source = http://www.signalyst.com/bins/hqplayer4desktop_4.0.0-1_amd64.deb
+ sha256sums = SKIP
+
+pkgname = hqplayer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aad18af631b8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: AudioLinux <audiolinux AT fastmail DOT fm>
+
+pkgname=hqplayer
+_debpkgver=4.0.0-1
+pkgver=4.0.0
+pkgrel=1
+pkgdesc="The high-end upsampling multichannel software HD-audio player"
+arch=('x86_64')
+url="http://www.signalyst.com/consumer.html"
+license=('custom')
+depends=('glibc' 'gcc-libs' 'libx11' 'qt5-base' 'qt5-script' 'qt5-quickcontrols' 'qt5-quickcontrols2' 'qt5-svg' 'qt5-declarative' 'qt5-graphicaleffects' 'libmicrohttpd' 'alsa-lib' 'flac')
+optdepends=('evince: hqplayer manual reading')
+source=("http://www.signalyst.com/bins/hqplayer4desktop_"$_debpkgver"_amd64.deb")
+sha256sums=('SKIP')
+
+package() {
+ cd "$srcdir"
+ bsdtar xf data.tar.xz -C "$pkgdir"
+ install -Dm644 "$pkgdir/usr/share/doc/hqplayer4desktop/copyright" "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+ rm "$pkgdir/usr/share/doc/hqplayer4desktop/copyright"
+}