summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-x.SRCINFO7
-rwxr-xr-xPKGBUILD8
-rw-r--r--hqplayer4.install6
3 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a963ef24e422..2e3446ef334a 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = hqplayer4
pkgdesc = The high-end upsampling multichannel software HD-audio player
pkgver = 4.21.1
- pkgrel = 1
+ pkgrel = 2
url = http://www.signalyst.com/consumer.html
install = hqplayer4.install
arch = x86_64
+ arch = x86_64_v3
license = custom
depends = glibc
depends = gcc-libs
@@ -20,10 +21,6 @@ pkgbase = hqplayer4
depends = mpg123
optdepends = hqplayer-client
optdepends = evince: hqplayer manual reading
- provides = hqplayer
- conflicts = hqplayer-embedded-amd
- conflicts = hqplayer-embedded-sse
- conflicts = hqplayer-embedded
options = !strip
source = https://www.signalyst.com/bins/hqplayer4desktop_4.21.1-106avx2_amd64.deb
sha256sums = a7c11af341bf8a7f1a51fd7e15ba6515404f3bae71cf4a9e8e6866a5263d34ae
diff --git a/PKGBUILD b/PKGBUILD
index 2ef57172ed25..9e4894f91f74 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,13 @@
pkgname=hqplayer4
pkgver=4.21.1
_debpkgver=4.21.1-106avx2
-pkgrel=1
+pkgrel=2
pkgdesc="The high-end upsampling multichannel software HD-audio player"
-arch=('x86_64')
+arch=('x86_64' 'x86_64_v3')
url="http://www.signalyst.com/consumer.html"
license=('custom')
depends=('glibc' 'gcc-libs' 'libx11' 'libusb-compat' 'openmp' 'qt6-base' 'qt6-charts' 'libmicrohttpd' 'alsa-lib' 'flac' 'wavpack' 'mpg123')
optdepends=('hqplayer-client' 'evince: hqplayer manual reading')
-conflicts=('hqplayer-embedded-amd' 'hqplayer-embedded-sse' 'hqplayer-embedded')
-provides=('hqplayer')
source=("https://www.signalyst.com/bins/hqplayer4desktop_"$_debpkgver"_amd64.deb")
sha256sums=('a7c11af341bf8a7f1a51fd7e15ba6515404f3bae71cf4a9e8e6866a5263d34ae')
options=(!strip)
@@ -22,8 +20,6 @@ cd $srcdir
bsdtar xf data.tar.zst -C "$pkgdir"
install -Dm644 "$pkgdir/usr/share/doc/hqplayer4desktop/copyright" "$pkgdir/usr/share/licenses/$pkgname/COPYING"
rm "$pkgdir/usr/share/doc/hqplayer4desktop/copyright"
-install -Dm755 "$pkgdir"/opt/hqplayer4desktop/lib/libsgllnx64-2.29.02.so "$pkgdir"/usr/lib/libsgllnx64-2.29.02.so
-rm -rf "$pkgdir/opt"
rm $pkgdir/usr/bin/hqplayer4client
rm $pkgdir/usr/share/applications/hqplayer4-client.desktop
rm $pkgdir/usr/share/pixmaps/hqplayer4-client.png
diff --git a/hqplayer4.install b/hqplayer4.install
index 0379a9a380bf..215957ea4f47 100644
--- a/hqplayer4.install
+++ b/hqplayer4.install
@@ -19,6 +19,9 @@ if [ ! -f "/etc/pki/tls/certs/ca-bundle.crt" ]; then
mkdir -p /etc/pki/tls/certs
ln -s /etc/ssl/certs/ca-certificates.crt /etc/pki/tls/certs/ca-bundle.crt
fi
+if [ ! -f "libsgllnx64-2.29.02.so" ]; then
+ln -s /opt/hqplayer4desktop/lib/libsgllnx64-2.29.02.so libsgllnx64-2.29.02.so
+fi
}
post_upgrade() {
@@ -42,4 +45,7 @@ if [ ! -f "/etc/pki/tls/certs/ca-bundle.crt" ]; then
mkdir -p /etc/pki/tls/certs
ln -s /etc/ssl/certs/ca-certificates.crt /etc/pki/tls/certs/ca-bundle.crt
fi
+if [ ! -f "libsgllnx64-2.29.02.so" ]; then
+ln -s /opt/hqplayer4desktop/lib/libsgllnx64-2.29.02.so libsgllnx64-2.29.02.so
+fi
}