summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--vim-keybindings.patch14
3 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bc61c95edeb6..32024f3a9050 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = htop-vim
pkgdesc = Interactive process viewer with a Vim keybindings patch
- pkgver = 3.2.0
+ pkgver = 3.2.1
pkgrel = 1
url = https://htop.dev/
arch = x86_64
@@ -17,9 +17,9 @@ pkgbase = htop-vim
provides = htop
conflicts = htop
options = !emptydirs
- source = https://github.com/htop-dev/htop/archive/3.2.0/htop-3.2.0.tar.gz
+ source = https://github.com/htop-dev/htop/archive/3.2.1/htop-3.2.1.tar.gz
source = vim-keybindings.patch
- sha256sums = 1a1dd174cc828521fe5fd0e052cff8c30aa50809cf80d3ce3a481c37d476ac54
- sha256sums = 19f0386384d5b65072b0f66232c3b032185e545e80266b74ae1db951662a010a
+ sha256sums = b5ffac1949a8daaabcffa659c0964360b5008782aae4dfa7702d2323cfb4f438
+ sha256sums = dd0fbe1685d4e7966c18dcfa9946da436a1d198d071def5ff7c39df8126e9483
pkgname = htop-vim
diff --git a/PKGBUILD b/PKGBUILD
index faa30eb1aaeb..2d84cae62128 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=htop
pkgname="${_pkgname}-vim"
-pkgver=3.2.0
+pkgver=3.2.1
pkgrel=1
pkgdesc='Interactive process viewer with a Vim keybindings patch'
arch=('x86_64')
@@ -19,8 +19,8 @@ options=('!emptydirs')
source=("https://github.com/htop-dev/htop/archive/${pkgver}/${_pkgname}-${pkgver}.tar.gz"
'vim-keybindings.patch'
)
-sha256sums=('1a1dd174cc828521fe5fd0e052cff8c30aa50809cf80d3ce3a481c37d476ac54'
- '19f0386384d5b65072b0f66232c3b032185e545e80266b74ae1db951662a010a')
+sha256sums=('b5ffac1949a8daaabcffa659c0964360b5008782aae4dfa7702d2323cfb4f438'
+ 'dd0fbe1685d4e7966c18dcfa9946da436a1d198d071def5ff7c39df8126e9483')
prepare() {
cd "${_pkgname}-${pkgver}"
diff --git a/vim-keybindings.patch b/vim-keybindings.patch
index 67e4e58a6e13..f34edd91832b 100644
--- a/vim-keybindings.patch
+++ b/vim-keybindings.patch
@@ -1,8 +1,8 @@
diff --git a/Action.c b/Action.c
-index ce3cd13..451d8ec 100644
+index b765248..50b32f5 100644
--- a/Action.c
+++ b/Action.c
-@@ -503,7 +503,7 @@ static const struct {
+@@ -507,7 +507,7 @@ static const struct {
const char* info;
} helpLeft[] = {
{ .key = " Tab: ", .roInactive = false, .info = "switch to next screen tab" },
@@ -11,16 +11,16 @@ index ce3cd13..451d8ec 100644
{ .key = " Digits: ", .roInactive = false, .info = "incremental PID search" },
{ .key = " F3 /: ", .roInactive = false, .info = "incremental name search" },
{ .key = " F4 \\: ", .roInactive = false, .info = "incremental name filtering" },
-@@ -531,7 +531,7 @@ static const struct {
+@@ -535,7 +535,7 @@ static const struct {
{ .key = " Space: ", .roInactive = false, .info = "tag process" },
{ .key = " c: ", .roInactive = false, .info = "tag process and its children" },
{ .key = " U: ", .roInactive = false, .info = "untag all processes" },
- { .key = " F9 k: ", .roInactive = true, .info = "kill process/tagged processes" },
+ { .key = " F9 x: ", .roInactive = true, .info = "kill process/tagged processes" },
{ .key = " F7 ]: ", .roInactive = true, .info = "higher priority (root only)" },
- { .key = " F8 [: ", .roInactive = false, .info = "lower priority (+ nice)" },
+ { .key = " F8 [: ", .roInactive = true, .info = "lower priority (+ nice)" },
#if (defined(HAVE_LIBHWLOC) || defined(HAVE_AFFINITY))
-@@ -539,12 +539,12 @@ static const struct {
+@@ -543,12 +543,12 @@ static const struct {
#endif
{ .key = " e: ", .roInactive = false, .info = "show process environment" },
{ .key = " i: ", .roInactive = true, .info = "set IO priority" },
@@ -36,7 +36,7 @@ index ce3cd13..451d8ec 100644
{ .key = " F10 q: ", .roInactive = false, .info = "quit" },
{ .key = NULL, .info = NULL }
};
-@@ -718,12 +718,14 @@ void Action_setBindings(Htop_Action* keys) {
+@@ -747,12 +747,14 @@ void Action_setBindings(Htop_Action* keys) {
keys['H'] = actionToggleUserlandThreads;
keys['I'] = actionInvertSortOrder;
keys['K'] = actionToggleKernelThreads;
@@ -51,7 +51,7 @@ index ce3cd13..451d8ec 100644
keys['Z'] = actionTogglePauseProcessUpdate;
keys['['] = actionLowerPriority;
keys['\014'] = actionRedraw; // Ctrl+L
-@@ -733,17 +735,15 @@ void Action_setBindings(Htop_Action* keys) {
+@@ -762,17 +764,15 @@ void Action_setBindings(Htop_Action* keys) {
keys['a'] = actionSetAffinity;
keys['c'] = actionTagAllChildren;
keys['e'] = actionShowEnvScreen;