summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD30
2 files changed, 23 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b43d80e45c9c..dc995d18c0ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = httpdirfs
pkgdesc = A filesystem which allows you to mount HTTP directory listings
- pkgver = 1.2.0
- pkgrel = 1
+ pkgver = 1.2.5
+ pkgrel = 2
url = https://github.com/fangfufu/httpdirfs
- arch = any
+ arch = x86_64
license = GPL
- makedepends = gumbo-parser
- makedepends = fuse2
- makedepends = openssl
+ makedepends = help2man
+ makedepends = doxygen
+ makedepends = graphviz
depends = gumbo-parser
depends = fuse2
- depends = openssl
- source = https://github.com/fangfufu/httpdirfs/archive/1.2.0.tar.gz
- md5sums = 5c9c31c39217da0a9ff44b4cae5704eb
+ depends = curl
+ depends = expat
+ source = httpdirfs-1.2.5.tar.gz::https://github.com/fangfufu/httpdirfs/archive/1.2.5.tar.gz
+ md5sums = 77910de057b196ed7b3714f7a0698203
pkgname = httpdirfs
-
diff --git a/PKGBUILD b/PKGBUILD
index e929448039e7..b3fb286ed9df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,25 @@
# Maintainer: Owen Trigueros <owentrigueros@gmail.com>
pkgname=httpdirfs
-pkgver=1.2.0
-pkgrel=1
+pkgver=1.2.5
+pkgrel=2
pkgdesc="A filesystem which allows you to mount HTTP directory listings"
-arch=('any')
+arch=('x86_64')
url="https://github.com/fangfufu/httpdirfs"
license=('GPL')
-depends=('gumbo-parser' 'fuse2' 'openssl')
-makedepends=('gumbo-parser' 'fuse2' 'openssl')
-source=("https://github.com/fangfufu/$pkgname/archive/$pkgver.tar.gz")
-md5sums=("5c9c31c39217da0a9ff44b4cae5704eb")
+depends=('gumbo-parser' 'fuse2' 'curl' 'expat')
+makedepends=('help2man' 'doxygen' 'graphviz')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/fangfufu/$pkgname/archive/$pkgver.tar.gz")
+md5sums=("77910de057b196ed7b3714f7a0698203")
-prepare() {
- cd "$pkgname-$pkgver"
-
- # Replace /usr/local prefix with /usr
- sed -i 's/^prefix ?= \/usr\/local/prefix ?= \/usr/' Makefile
-}
build() {
- cd "$pkgname-$pkgver"
- make
+ cd "$pkgname-$pkgver"
+ make man
+ make doc
+ make
}
package() {
- cd "$pkgname-$pkgver"
- make DESTDIR="$pkgdir" install
+ cd "$pkgname-$pkgver"
+ make prefix=/usr DESTDIR="$pkgdir" install
}