summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD38
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0ae6d53b2f1c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = huaweicloud-obs-obsfs-git
+ pkgdesc = A file system tool provided by Object Storage Service (OBS) for mounting OBS parallel file systems
+ pkgver = 1.83.9ee91c6
+ pkgrel = 1
+ url = https://support.huaweicloud.com/intl/en-us/fstg-obs/obs_12_0001.html
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = libxml2
+ depends = curl
+ depends = fuse2
+ provides = huaweicloud-obs-obsfs
+ conflicts = huaweicloud-obs-obsfs
+ source = git+https://github.com/huaweicloud/huaweicloud-obs-obsfs.git
+ md5sums = SKIP
+
+pkgname = huaweicloud-obs-obsfs-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1e81f09758b5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Misaka13514 <Misaka13514 at gmail dot com>
+pkgname=huaweicloud-obs-obsfs-git
+pkgver=1.83.9ee91c6
+pkgrel=1
+pkgdesc="A file system tool provided by Object Storage Service (OBS) for mounting OBS parallel file systems"
+arch=('x86_64')
+url="https://support.huaweicloud.com/intl/en-us/fstg-obs/obs_12_0001.html"
+license=('GPL2')
+depends=('libxml2' 'curl' 'fuse2')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+#backup=(etc/passwd-obsfs)
+#install='huaweicloud-obs-obsfs-git.install'
+source=('git+https://github.com/huaweicloud/huaweicloud-obs-obsfs.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "%s.%s" "$(grep AC_INIT configure.ac | grep -P "\d+.\d+" -o)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ chmod +x ./autogen.sh
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ make DESTDIR="$pkgdir/" install
+}