summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--.nvchecker.toml4
-rw-r--r--PKGBUILD27
3 files changed, 24 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 683cbce8c08b..1002bf58d564 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = hunspell-da
pkgdesc = Danish hunspell dictionaries
- pkgver = 2.7.273
+ pkgver = 2.8.098
pkgrel = 1
url = https://stavekontrolden.dk/
arch = any
- license = GPL2
- license = LGPL2.1
- license = MPL
+ license = GPL-3.0-only AND (GPL-2.0-only AND LGPL-2.1-only AND MPL-1.1)
optdepends = hunspell: the spell checking libraries and apps
- source = https://stavekontrolden.dk/dictionaries/da_DK/da_DK-2.7.273.aff
- source = https://stavekontrolden.dk/dictionaries/da_DK/da_DK-2.7.273.dic
- b2sums = a7bd3f6635671780753d66a0fd3f7ecb4a2804283ba18343af21ef3076071a342f2f1f20c043b0f3908548d659dc42bbb20b93fa12758e4f7842f95643df5f8b
- b2sums = 49b978e9c5cebd84909640b1781cc0e50d06002b8337842dfd9242c8aa3b5c24a025c6a0323de640e0804928e7109477c91e9689564f8b10f303f3d03ec07e52
+ source = https://stavekontrolden.dk/dictionaries/da_DK/da_DK-2.8.098.aff
+ source = https://stavekontrolden.dk/dictionaries/da_DK/da_DK-2.8.098.dic
+ b2sums = 3bef0a2355c095466dd47713b921065d13098dc5aa98dd815f4620993fde08a52b3e50d6284928ecec56b66b1ef65874aa6b8e0bc68ef453807bdbf530e94476
+ b2sums = 69aa516202ae76fbffd191385d7e1e986a9f92eaa494e4c593e137082d23972f384afcb6666629faa30bd82ec045accffd6ed3654f462d420ca5410e544b5916
pkgname = hunspell-da
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..385d85cee9a1
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,4 @@
+[hunspell-da]
+source = "regex"
+url = "https://stavekontrolden.dk/?dictionaries=1"
+regex = "da_DK-((?:\\d|\\.)+)\\.aff"
diff --git a/PKGBUILD b/PKGBUILD
index ff53d0361ef5..c5267ada711f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,18 @@
# Contributor: adament <adament@adament.net>
# Contributor: Jamie Magee <jamie dot magee at gmail dot com>
pkgname=hunspell-da
-pkgver=2.7.273
+pkgver=2.8.098
pkgrel=1
pkgdesc="Danish hunspell dictionaries"
arch=('any')
-url="https://stavekontrolden.dk/"
-license=('GPL2' 'LGPL2.1' 'MPL')
-optdepends=('hunspell: the spell checking libraries and apps')
+url='https://stavekontrolden.dk/'
+license=('GPL-3.0-only AND (GPL-2.0-only AND LGPL-2.1-only AND MPL-1.1)')
+optdepends=(
+ 'hunspell: the spell checking libraries and apps')
source=("https://stavekontrolden.dk/dictionaries/da_DK/da_DK-$pkgver.aff"
"https://stavekontrolden.dk/dictionaries/da_DK/da_DK-$pkgver.dic")
-b2sums=('a7bd3f6635671780753d66a0fd3f7ecb4a2804283ba18343af21ef3076071a342f2f1f20c043b0f3908548d659dc42bbb20b93fa12758e4f7842f95643df5f8b'
- '49b978e9c5cebd84909640b1781cc0e50d06002b8337842dfd9242c8aa3b5c24a025c6a0323de640e0804928e7109477c91e9689564f8b10f303f3d03ec07e52')
+b2sums=('3bef0a2355c095466dd47713b921065d13098dc5aa98dd815f4620993fde08a52b3e50d6284928ecec56b66b1ef65874aa6b8e0bc68ef453807bdbf530e94476'
+ '69aa516202ae76fbffd191385d7e1e986a9f92eaa494e4c593e137082d23972f384afcb6666629faa30bd82ec045accffd6ed3654f462d420ca5410e544b5916')
build() {
# Rename downloaded files
@@ -26,11 +27,11 @@ package() {
install -dm755 "${pkgdir}"/usr/share/hunspell
install -m644 da_DK.dic da_DK.aff $pkgdir/usr/share/hunspell
- # the symlinks
- install -dm755 ${pkgdir}/usr/share/myspell/dicts
- pushd "$pkgdir"/usr/share/myspell/dicts
- for file in $pkgdir/usr/share/hunspell/*; do
- ln -sv /usr/share/hunspell/"$(basename $file)" .
- done
- popd
+ # myspell/dicts symlinks
+ install -dm755 "${pkgdir}"/usr/share/myspell/dicts
+ pushd "$pkgdir"/usr/share/myspell/dicts > /dev/null
+ for file in "${pkgdir}"/usr/share/hunspell/*; do
+ ln -sv /usr/share/hunspell/"$(basename $file)" .
+ done
+ popd > /dev/null
}