summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD21
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bae7dee6b72e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = hunspell-eu-es
+ pkgdesc = Basque hunspell dictionary
+ pkgver = 1.2
+ pkgrel = 1
+ url = http://extensions.libreoffice.org/extension-center/xuxen-5-zuzentzaile-ortografikoa
+ arch = any
+ license = GPL
+ optdepends = hunspell: the spell checking libraries and apps
+ source = http://extensions.libreoffice.org/extension-center/xuxen-5-zuzentzaile-ortografikoa/releases/1.2/xuxen_openoffice_libreoffice.oxt
+ sha256sums = e3ba62d4107c780a91fd4afb5e021e4c89ebed25d387d567be353fdf9407951f
+
+pkgname = hunspell-eu-es
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c26780ebdcf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Christian Pinedo <chr.pinedo@gmail.com>
+
+pkgname=hunspell-eu-es
+pkgver=1.2
+pkgrel=1
+pkgdesc="Basque hunspell dictionary"
+arch=('any')
+url="http://extensions.libreoffice.org/extension-center/xuxen-5-zuzentzaile-ortografikoa"
+license=('GPL')
+optdepends=("hunspell: the spell checking libraries and apps")
+source=("$url/releases/$pkgver/xuxen_openoffice_libreoffice.oxt")
+sha256sums=('e3ba62d4107c780a91fd4afb5e021e4c89ebed25d387d567be353fdf9407951f')
+
+package() {
+ install -D -m644 ${srcdir}/eu_ES.dic ${pkgdir}/usr/share/hunspell/eu_ES.dic
+ install -D -m644 ${srcdir}/eu_ES.aff ${pkgdir}/usr/share/hunspell/eu_ES.aff
+
+ mkdir -p ${pkgdir}/usr/share/myspell/dicts
+ ln -s /usr/share/hunspell/eu_ES.dic ${pkgdir}/usr/share/myspell/dicts/eu_ES.dic
+ ln -s /usr/share/hunspell/eu_ES.aff ${pkgdir}/usr/share/myspell/dicts/eu_ES.aff
+}