summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--[-rwxr-xr-x].SRCINFO3
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29328203af93..4b418dd10ff6 100755..100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = hunspell-fr
pkgdesc = French Hunspell dictionary
pkgver = 6.4.1
- pkgrel = 1
+ pkgrel = 2
url = https://grammalecte.net/home.php?prj=fr
arch = any
license = MPL2
+ makedepends = qt5-webengine
provides = hunspell-fr
conflicts = hunspell-fr
source = https://grammalecte.net/download/fr/hunspell-french-dictionaries-v6.4.1.zip
diff --git a/PKGBUILD b/PKGBUILD
index e5833d6d3c0a..94366293fe70 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,13 @@
pkgbase='hunspell-fr'
pkgname=($pkgbase-{'classical','comprehensive','modern','revised'})
pkgver=6.4.1
-pkgrel=1
+pkgrel=2
pkgdesc="French Hunspell dictionary"
arch=(any)
_base_url="https://grammalecte.net"
url="${_base_url}/home.php?prj=fr"
license=('MPL2')
+makedepends=('qt5-webengine')
conflicts=('hunspell-fr')
provides=('hunspell-fr')
source=("${_base_url}/download/fr/hunspell-french-dictionaries-v${pkgver}.zip")
@@ -58,4 +59,11 @@ _package() {
popd
install -Dm644 README_dict_fr.txt "${pkgdir}"/usr/share/doc/${pkgname}/README_dict_fr.txt
+
+ # Install webengine dictionaries
+ install -d "$pkgdir"/usr/share/qt/qtwebengine_dictionaries/
+ for _file in "$pkgdir"/usr/share/hunspell/*.dic; do
+ _filename=$(basename $_file)
+ qwebengine_convert_dict $_file "$pkgdir"/usr/share/qt/qtwebengine_dictionaries/${_filename/\.dic/\.bdic}
+ done
}