summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD13
2 files changed, 14 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f8a7ae846752..90ccd7db1bc3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = hunspell-fr-ungendered
pkgdesc = French ungendered hunspell dictionary
pkgver = 6.4.1
- pkgrel = 1
- url = https://github.com/RadicaliseesSurInternet/hunspell-inclusif
+ pkgrel = 2
+ url = https://github.com/ariasuni/hunspell-inclusif
arch = any
license = MPL2
makedepends = python
+ makedepends = qt5-webengine
provides = hunspell-fr
conflicts = hunspell-fr
- source = https://github.com/RadicaliseesSurInternet/hunspell-inclusif/archive/6.4.1.tar.gz
+ source = https://github.com/ariasuni/hunspell-inclusif/archive/6.4.1.tar.gz
sha256sums = 4b0325f5866def67314b99bda65709df1a965deb1939332e68890fd2d64e8b69
pkgname = hunspell-fr-ungendered-classical
diff --git a/PKGBUILD b/PKGBUILD
index 5cdbb6fe9cb1..f1ce17791eac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
pkgbase='hunspell-fr-ungendered'
pkgname=("$pkgbase"-{'classical','comprehensive','modern','revised'})
pkgver=6.4.1
-pkgrel=1
+pkgrel=2
pkgdesc="French ungendered hunspell dictionary"
arch=(any)
-url="https://github.com/RadicaliseesSurInternet/hunspell-inclusif"
+url="https://github.com/ariasuni/hunspell-inclusif"
license=('MPL2')
-makedepends=('python')
+makedepends=('python' 'qt5-webengine')
conflicts=('hunspell-fr')
provides=('hunspell-fr')
source=("${url}/archive/${pkgver}.tar.gz")
@@ -61,4 +61,11 @@ _package() {
popd
install -Dm644 README.md "${pkgdir}"/usr/share/doc/${pkgname}/README.md
+
+ # Install webengine dictionaries
+ install -d "$pkgdir"/usr/share/qt/qtwebengine_dictionaries/
+ for _file in "$pkgdir"/usr/share/hunspell/*.dic; do
+ _filename=$(basename $_file)
+ qwebengine_convert_dict $_file "$pkgdir"/usr/share/qt/qtwebengine_dictionaries/${_filename/\.dic/\.bdic}
+ done
}