summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD33
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0d15dd91e725
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = hunspell-hr
+ pkgdesc = Croatian dictionary for Hunspell
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/krunose/hunspell-hr
+ arch = any
+ license = MIT,
+ license = LGPL/SISSL
+ optdepends = hunspell: the spell checking libraries and apps
+ source = https://github.com/krunose/hunspell-hr/archive/9ae404a8840fe9525deea22ef0a8fd95948fd544.zip
+ md5sums = 74b7536617a62455c5f8625d3463f581
+
+pkgname = hunspell-hr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e742493b15a6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Miro Bezjak <bezjak.miro at gmail dot com>
+# based upon: https://aur.archlinux.org/packages/hunspell-bg/
+
+pkgname=hunspell-hr
+pkgver=1.0
+pkgrel=1
+pkgdesc='Croatian dictionary for Hunspell'
+arch=('any')
+url="https://github.com/krunose/hunspell-hr"
+license=('MIT', 'LGPL/SISSL')
+optdepends=('hunspell: the spell checking libraries and apps')
+source=('https://github.com/krunose/hunspell-hr/archive/9ae404a8840fe9525deea22ef0a8fd95948fd544.zip')
+md5sums=('74b7536617a62455c5f8625d3463f581')
+
+package() {
+ cd "${srcdir}"/hunspell-hr-*
+ install -dm755 ${pkgdir}/usr/share/hunspell
+
+ install -m644 hr_HR.dic ${pkgdir}/usr/share/hunspell/hr_HR.dic
+ install -m644 hr_HR.aff ${pkgdir}/usr/share/hunspell/hr_HR.aff
+
+ # the symlinks
+ install -dm755 ${pkgdir}/usr/share/myspell/dicts
+ pushd ${pkgdir}/usr/share/myspell/dicts
+ for file in ${pkgdir}/usr/share/hunspell/*; do
+ ln -sv /usr/share/hunspell/$(basename ${file}) .
+ done
+ popd
+
+ # docs
+ install -dm755 ${pkgdir}/usr/share/doc/${pkgname}
+ install -m644 README_hr_HR.txt ${pkgdir}/usr/share/doc/${pkgname}/
+}