summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD23
2 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9aa71152f30c..8359690e55a7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = hunspell-ko
pkgdesc = Korean hunspell dictionary
pkgver = 0.7.92
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/spellcheck-ko/hunspell-dict-ko
arch = any
license = GPL3
+ makedepends = qt5-webengine
optdepends = hunspell: the spell checking libraries and apps
source = https://github.com/spellcheck-ko/hunspell-dict-ko/releases/download/0.7.92/ko-aff-dic-0.7.92.zip
sha512sums = 300e574c7221841801f0d4b114abaa3b15196b69cb25f98ed784c820d125bd60e6fe6ca6cc76dca07de9382e957acd4bc337fa87b84f809b13f703ebe47baa45
diff --git a/PKGBUILD b/PKGBUILD
index 3224bef9c58a..36b3df783cec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,19 @@
pkgname=hunspell-ko
pkgver=0.7.92
-pkgrel=4
+pkgrel=5
pkgdesc="Korean hunspell dictionary"
arch=('any')
url='https://github.com/spellcheck-ko/hunspell-dict-ko'
license=('GPL3')
-#makedepends=('qt5-webengine')
+makedepends=('qt5-webengine')
optdepends=('hunspell: the spell checking libraries and apps')
source=(https://github.com/spellcheck-ko/hunspell-dict-ko/releases/download/${pkgver}/ko-aff-dic-${pkgver}.zip)
sha512sums=('300e574c7221841801f0d4b114abaa3b15196b69cb25f98ed784c820d125bd60e6fe6ca6cc76dca07de9382e957acd4bc337fa87b84f809b13f703ebe47baa45')
package() {
cd "$srcdir/ko-aff-dic-$pkgver"
- install -dm755 "${pkgdir}/usr/share/hunspell"
- install -m644 ko.dic "${pkgdir}"/usr/share/hunspell
- install -m644 ko.aff "${pkgdir}"/usr/share/hunspell
+ install -vDm 644 ko.dic ko.aff -t "$pkgdir/usr/share/hunspell"
pushd "$pkgdir/usr/share/hunspell/"
ko_KR_aliases="ko_KR"
@@ -24,14 +22,17 @@ package() {
ln -s ko.aff $lang.aff
ln -s ko.dic $lang.dic
done
+ # Remove easter egg for convert to qt webengine dictionary
+ # It's temp, because this line is ugly
+ sed -i '14265d' ko.dic
popd
- # Install webengine dictionaries (not able to convert)
-# install -d "$pkgdir"/usr/share/qt/qtwebengine_dictionaries/
-# for _file in "$pkgdir"/usr/share/hunspell/*.dic; do
-# _filename="$(basename "$_file")"
-# qwebengine_convert_dict "$_file" "$pkgdir"/usr/share/qt/qtwebengine_dictionaries/${_filename/\.dic/\.bdic}
-# done
+ # Install webengine dictionaries
+ install -d "$pkgdir"/usr/share/qt/qtwebengine_dictionaries/
+ for _file in "$pkgdir"/usr/share/hunspell/*.dic; do
+ _filename="$(basename "$_file")"
+ qwebengine_convert_dict "$_file" "$pkgdir"/usr/share/qt/qtwebengine_dictionaries/${_filename/\.dic/\.bdic}
+ done
# myspell symlinks
install -dm755 "${pkgdir}"/usr/share/myspell/dicts