summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD47
2 files changed, 24 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c81cf6430544..3bd0ee6fc409 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
pkgbase = hunspell-ko
pkgdesc = Korean dictionary for hunspell
pkgver = 0.7.92
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/spellcheck-ko/hunspell-dict-ko
arch = any
license = GPL3
- license = custom
makedepends = python-yaml
depends = hunspell>=1.3.1
source = hunspell-ko-0.7.92.tar.gz::https://github.com/spellcheck-ko/hunspell-dict-ko/archive/0.7.92.tar.gz
sha1sums = 41085dac1529224d96bfef13fa7fc836aeee5bda
pkgname = hunspell-ko
-
diff --git a/PKGBUILD b/PKGBUILD
index 0b58f556dc44..7285357f6c35 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,41 @@
# Maintainer: OctopusET
+
pkgname=hunspell-ko
pkgver=0.7.92
-pkgrel=1
+pkgrel=2
pkgdesc="Korean dictionary for hunspell"
arch=('any')
url='https://github.com/spellcheck-ko/hunspell-dict-ko'
-license=('GPL3' 'custom')
+license=('GPL3')
depends=('hunspell>=1.3.1')
-makedepends=(
-'python-yaml'
-)
+makedepends=('python-yaml')
+
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/spellcheck-ko/hunspell-dict-ko/archive/${pkgver}.tar.gz")
sha1sums=('41085dac1529224d96bfef13fa7fc836aeee5bda')
build() {
- cd "$srcdir/hunspell-dict-ko-$pkgver"
- make VERSION=$pkgver DESTDIR="$pkgdir" PREFIX=/usr
+ cd "$srcdir/hunspell-dict-ko-$pkgver"
+ make VERSION=$pkgver DESTDIR="$pkgdir" PREFIX=/usr
}
package() {
- cd "$srcdir/hunspell-dict-ko-$pkgver"
- install -dm755 "${pkgdir}/usr/share/hunspell"
- install -m644 ko.dic "${pkgdir}"/usr/share/hunspell
- install -m644 ko.aff "${pkgdir}"/usr/share/hunspell
- pushd "$pkgdir"/usr/share/hunspell
- for file in ko.*; do
- ln -s ko_KR."${file#*.}"
- done
- popd
+ cd "$srcdir/hunspell-dict-ko-$pkgver"
+ install -dm755 "${pkgdir}/usr/share/hunspell"
+ install -m644 ko.dic "${pkgdir}"/usr/share/hunspell
+ install -m644 ko.aff "${pkgdir}"/usr/share/hunspell
+ pushd "$pkgdir"/usr/share/hunspell
+ for file in ko.*; do
+ ln -s ko_KR."${file#*.}"
+ done
+ popd
# symlinks
- install -dm755 "${pkgdir}"/usr/share/myspell/dicts
- pushd "$pkgdir"/usr/share/myspell/dicts
- for file in "${pkgdir}"/usr/share/hunspell/*; do
- ln -sv /usr/share/hunspell/$(basename $file) .
- done
- popd
+ install -dm755 "${pkgdir}"/usr/share/myspell/dicts
+ pushd "$pkgdir"/usr/share/myspell/dicts
+ for file in "${pkgdir}"/usr/share/hunspell/*; do
+ ln -sv /usr/share/hunspell/$(basename $file) .
+ done
+ popd
# licenses
- install -Dm644 LICENSE.md $pkgdir/usr/share/licenses/$pkgname/LICENSE
-
+ install -Dm644 LICENSE.md $pkgdir/usr/share/licenses/$pkgname/LICENSE
}