summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD26
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5de0f568e198
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = hw-probe-git
+ pkgdesc = Tool to probe for hardware, check its operability and upload result to the Linux hardware DB: http://linux-hardware.org
+ pkgver = 1.2+0.gc5f178b
+ pkgrel = 1
+ url = https://github.com/linuxhw/hw-probe
+ arch = any
+ license = GPLv2
+ depends = perl>=5
+ depends = hwinfo
+ depends = curl
+ depends = dmidecode
+ depends = pciutils
+ depends = usbutils
+ depends = net-tools
+ optdepends = hdparm
+ optdepends = smartmontools
+ optdepends = inxi
+ optdepends = pnputils
+ provides = hw-probe=1.2
+ conflicts = hw-probe
+ source = https://github.com/linuxhw/hw-probe
+ md5sums = SKIP
+
+pkgname = hw-probe-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c82ba50b8dfe
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+/hw-probe/
+/*.pkg.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0daa25774663
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Eric Engestrom <aur [at] engestrom [dot] ch>
+
+pkgname=hw-probe-git
+pkgver=1.2+0.gc5f178b
+pkgrel=1
+pkgdesc="Tool to probe for hardware, check its operability and upload result to the Linux hardware DB: http://linux-hardware.org"
+arch=('any')
+url="https://github.com/linuxhw/hw-probe"
+license=('GPLv2')
+source=("git+$url")
+md5sums=('SKIP')
+depends=('perl>=5' 'hwinfo' 'curl' 'dmidecode' 'pciutils' 'usbutils' 'net-tools')
+optdepends=('hdparm' 'smartmontools' 'inxi' 'pnputils')
+conflicts=('hw-probe')
+provides=("hw-probe=${pkgver%+*}")
+
+pkgver() {
+ cd "$srcdir/hw-probe"
+ git describe --long | sed 's/-/+/; s/-/./'
+}
+
+package() {
+ cd "$srcdir/hw-probe"
+ install -dm755 "$pkgdir"/usr
+ make install prefix="$pkgdir"/usr
+}