summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO42
-rw-r--r--PKGBUILD80
-rw-r--r--hybris-ready.install11
3 files changed, 133 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4c8af0b7b6e8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,42 @@
+pkgbase = hybris-ready
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/mickybart/
+ arch = armv7h
+ source = hybris-ready.install
+ source = gls-common::git+https://github.com/mickybart/gnulinux_support-common
+ source = bootanim::git+https://github.com/mickybart/hybris-ready-bootanim
+ md5sums = 9c7d863fd54b8651fb016b40a11173fb
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = hybris-ready
+ pkgdesc = hybris ready permit to fully support GNU/Linux and Android Hardware
+ install = hybris-ready.install
+ depends = hybris-device
+ depends = hybris-usb
+ depends = libhybris
+ depends = libgl
+ depends = libwayland-egl
+ depends = inotify-tools
+ optdepends = hybris-ready-bootanim: required to display a pretty boot animation
+
+pkgname = hybris-ready-bootanim
+ pkgdesc = Boot animation for hybris system
+ depends = hybris-ready
+ depends = hybris-ready-qt5-qpa-meta
+ depends = qt5-declarative
+ depends = qt5-svg
+
+pkgname = hybris-ready-qt5-qpa-meta
+ pkgdesc = Qt QPA Platform for hybris
+ depends = hybris-ready
+ depends = qt5-qpa-hwcomposer-plugin
+ depends = qt5-qpa-surfaceflinger-plugin
+
+pkgname = hybris-ready-plasma-support-meta
+ pkgdesc = plasma support for hybris system
+ depends = hybris-ready
+ depends = qt5-wayland-compositor
+ depends = kwin-hybris
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d3ceaa285c61
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,80 @@
+# Maintainer: Michael Serpieri <mickybart@pygoscelis.org>
+
+pkgbase=hybris-ready
+pkgname=('hybris-ready' 'hybris-ready-bootanim' 'hybris-ready-qt5-qpa-meta' 'hybris-ready-plasma-support-meta')
+pkgver=0.1
+pkgrel=1
+arch=('armv7h')
+url="https://github.com/mickybart/"
+license=('')
+makedepends=()
+source=('hybris-ready.install'
+ 'gls-common::git+https://github.com/mickybart/gnulinux_support-common'
+ 'bootanim::git+https://github.com/mickybart/hybris-ready-bootanim')
+md5sums=('9c7d863fd54b8651fb016b40a11173fb'
+ 'SKIP'
+ 'SKIP')
+
+build() {
+ cd ${srcdir}
+
+}
+
+package_hybris-ready() {
+ pkgdesc="hybris ready permit to fully support GNU/Linux and Android Hardware"
+ depends=('hybris-device' 'hybris-usb'
+ 'libhybris' 'libgl' 'libwayland-egl'
+ 'inotify-tools')
+ optdepends=('hybris-ready-bootanim: required to display a pretty boot animation')
+ install='hybris-ready.install'
+
+ cd ${srcdir}
+
+ # services for hybris-ready
+ install -d ${pkgdir}/usr/bin
+ install -m 755 gls-common/init/android-init ${pkgdir}/usr/bin/
+
+ install -d ${pkgdir}/usr/lib/systemd/system/
+ install -m 644 gls-common/systemd/units/hybris-ready.service ${pkgdir}/usr/lib/systemd/system/
+ install -m 644 gls-common/systemd/units/hybris-ready-completed.service ${pkgdir}/usr/lib/systemd/system/
+
+ # special services and target for Android Hw
+ install -m 644 gls-common/systemd/units/hybris-reboot-bootloader.service ${pkgdir}/usr/lib/systemd/system/
+ install -m 644 gls-common/systemd/units/hybris-reboot-recovery.service ${pkgdir}/usr/lib/systemd/system/
+ install -m 644 gls-common/systemd/units/bootloader.target ${pkgdir}/usr/lib/systemd/system/
+ install -m 644 gls-common/systemd/units/recovery.target ${pkgdir}/usr/lib/systemd/system/
+
+}
+
+package_hybris-ready-bootanim() {
+ pkgdesc="Boot animation for hybris system"
+ depends=('hybris-ready'
+ 'hybris-ready-qt5-qpa-meta'
+ 'qt5-declarative' 'qt5-svg')
+
+ cd ${srcdir}
+
+ # share
+ install -d ${pkgdir}/usr/share/hybris-ready-bootanim/
+ cp -r ${srcdir}/bootanim/bootanim/* ${pkgdir}/usr/share/hybris-ready-bootanim/
+ ln -s archlinux.qml ${pkgdir}/usr/share/hybris-ready-bootanim/active.qml
+
+ # Boot Animation service
+ install -d ${pkgdir}/usr/lib/systemd/system/
+ install -m 644 ${srcdir}/bootanim/systemd/hybris-ready-bootanim.service ${pkgdir}/usr/lib/systemd/system/
+
+}
+
+package_hybris-ready-qt5-qpa-meta() {
+ pkgdesc="Qt QPA Platform for hybris"
+ depends=('hybris-ready'
+ 'qt5-qpa-hwcomposer-plugin' 'qt5-qpa-surfaceflinger-plugin')
+
+}
+
+package_hybris-ready-plasma-support-meta() {
+ pkgdesc="plasma support for hybris system"
+ depends=('hybris-ready' 'qt5-wayland-compositor' 'kwin-hybris')
+
+}
+
diff --git a/hybris-ready.install b/hybris-ready.install
new file mode 100644
index 000000000000..b8503c24c87c
--- /dev/null
+++ b/hybris-ready.install
@@ -0,0 +1,11 @@
+
+post_install(){
+ printf '===> Android Hw\n'
+ printf ' To start Android services, bootanim, ... Please execute: \n\n'
+ printf ' systemctl enable hybris-ready.service\n\n'
+}
+
+post_upgrade(){
+ post_install
+}
+