summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--hydrus-client1
3 files changed, 5 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7539fe212791..fb2a2d14f224 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -20,11 +20,11 @@ pkgbase = hydrus
depends = python-send2trash
depends = python-html5lib
depends = python-requests
- depends = python-pyqt5
depends = python-qtpy
depends = python-pyopenssl
depends = emoji-font
depends = python-mpv
+ depends = qt5-python-bindings
optdepends = ffmpeg: show duration and other information on video thumbnails
optdepends = miniupnpc: automatic port forwarding
optdepends = desktop-file-utils: to add Hydrus to your desktop environment menus
@@ -41,7 +41,7 @@ pkgbase = hydrus
source = hydrus.desktop
sha256sums = SKIP
sha256sums = c3a171448f6904434d720a394c11ff405a960f17079a7ae2c4ef6e0395198ee0
- sha256sums = 7b0dbc6f38f9aaff409e435ba807199575166976b52715d6b54418f89dbde634
+ sha256sums = d2cb826ce0dd1892ab95fc3b14dbe6bd312210f653d0aea31938eeb7e361fdc5
sha256sums = 463841cc16059b516cc327cfbc30d3383e2236b085ba2d503e82f5be39444806
sha256sums = 9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923
diff --git a/PKGBUILD b/PKGBUILD
index f79d319eff54..07a330da8104 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,8 +15,8 @@ url=http://hydrusnetwork.github.io/hydrus/
depends=(python opencv python-beautifulsoup4 python-yaml
'python-lz4>=0.10.1' python-numpy python-twisted python-pillow
python-pysocks python-psutil python-send2trash python-html5lib
- python-requests python-pyqt5 python-qtpy python-pyopenssl
- emoji-font python-mpv)
+ python-requests python-qtpy python-pyopenssl emoji-font python-mpv
+ qt5-python-bindings)
makedepends=(git)
optdepends=('ffmpeg: show duration and other information on video thumbnails'
'miniupnpc: automatic port forwarding'
@@ -31,7 +31,7 @@ source=("${pkgbase}::git+https://github.com/hydrusnetwork/${pkgbase}.git#commit=
hydrus.desktop)
sha256sums=('SKIP'
'c3a171448f6904434d720a394c11ff405a960f17079a7ae2c4ef6e0395198ee0'
- '7b0dbc6f38f9aaff409e435ba807199575166976b52715d6b54418f89dbde634'
+ 'd2cb826ce0dd1892ab95fc3b14dbe6bd312210f653d0aea31938eeb7e361fdc5'
'463841cc16059b516cc327cfbc30d3383e2236b085ba2d503e82f5be39444806'
'9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923')
diff --git a/hydrus-client b/hydrus-client
index 9e9e822095d9..16b14ba225f3 100644
--- a/hydrus-client
+++ b/hydrus-client
@@ -1,3 +1,2 @@
#!/bin/sh
-export QT_API="${QT_API:-pyqt5}"
exec python -OO /opt/hydrus/client.pyw "$@"