summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--hydrus-client1
3 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0dc197ac075d..f0ec45f65551 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hydrus
pkgdesc = Danbooru-like image tagging and searching system for the desktop
pkgver = 374
- pkgrel = 1
+ pkgrel = 2
url = http://hydrusnetwork.github.io/hydrus/
install = hydrus.install
arch = any
@@ -21,7 +21,7 @@ pkgbase = hydrus
depends = python-html5lib
depends = python-requests
depends = hdf5
- depends = pyside2
+ depends = python-pyqt5
depends = python-qtpy
depends = qt5-charts
optdepends = ffmpeg: show duration and other information on video thumbnails
@@ -37,7 +37,7 @@ pkgbase = hydrus
source = hydrus.desktop
sha256sums = SKIP
sha256sums = 5cd4414cbf226eddc6319216a6def95e73c148f37746effaae983a4c690b71a2
- sha256sums = d2cb826ce0dd1892ab95fc3b14dbe6bd312210f653d0aea31938eeb7e361fdc5
+ sha256sums = 7b0dbc6f38f9aaff409e435ba807199575166976b52715d6b54418f89dbde634
sha256sums = 463841cc16059b516cc327cfbc30d3383e2236b085ba2d503e82f5be39444806
sha256sums = 9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923
diff --git a/PKGBUILD b/PKGBUILD
index 14e008223333..e47a821ec3ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ DOC_DIRS=(opt/hydrus/help)
pkgbase=hydrus
pkgname=(hydrus)
pkgver=374
-pkgrel=1
+pkgrel=2
pkgdesc="Danbooru-like image tagging and searching system for the desktop"
arch=(any)
license=(WTFPL)
@@ -15,7 +15,7 @@ url=http://hydrusnetwork.github.io/hydrus/
depends=(python opencv python-beautifulsoup4 python-yaml
'python-lz4>=0.10.1' python-numpy python-twisted python-pillow
python-pysocks python-psutil python-send2trash python-html5lib
- python-requests hdf5 pyside2 python-qtpy qt5-charts)
+ python-requests hdf5 python-pyqt5 python-qtpy qt5-charts)
makedepends=(git)
optdepends=('ffmpeg: show duration and other information on video thumbnails'
'miniupnpc: automatic port forwarding'
@@ -28,7 +28,7 @@ source=("${pkgbase}::git+https://github.com/hydrusnetwork/${pkgbase}.git#commit=
hydrus.desktop)
sha256sums=('SKIP'
'5cd4414cbf226eddc6319216a6def95e73c148f37746effaae983a4c690b71a2'
- 'd2cb826ce0dd1892ab95fc3b14dbe6bd312210f653d0aea31938eeb7e361fdc5'
+ '7b0dbc6f38f9aaff409e435ba807199575166976b52715d6b54418f89dbde634'
'463841cc16059b516cc327cfbc30d3383e2236b085ba2d503e82f5be39444806'
'9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923')
diff --git a/hydrus-client b/hydrus-client
index 16b14ba225f3..9e9e822095d9 100644
--- a/hydrus-client
+++ b/hydrus-client
@@ -1,2 +1,3 @@
#!/bin/sh
+export QT_API="${QT_API:-pyqt5}"
exec python -OO /opt/hydrus/client.pyw "$@"