summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--paths-in-opt.patch46
3 files changed, 28 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cfc4585731f8..735ce3677ce7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hydrus
pkgdesc = Danbooru-like image tagging and searching system for the desktop
- pkgver = 388
+ pkgver = 389
pkgrel = 1
url = http://hydrusnetwork.github.io/hydrus/
install = hydrus.install
@@ -33,13 +33,13 @@ pkgbase = hydrus
conflicts = hydrus-docs
conflicts = hydrus-sources
options = !strip
- source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=3edc910a965a3bd65fb11c1a7d9c00fd9be7ff6c
+ source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=5014c369b173b2a7c5f4ab5d9333b3e93a3fd0c8
source = paths-in-opt.patch
source = hydrus-client
source = hydrus-server
source = hydrus.desktop
sha256sums = SKIP
- sha256sums = e6c77ba667604cfb2e7d9959e79d3ad05c976dcc6297f25a8fcad730a63d2f11
+ sha256sums = 6f580d7a4313484fde4b085debe7e9657f01a2d31c4d5202e08ad33701a9d594
sha256sums = 7b0dbc6f38f9aaff409e435ba807199575166976b52715d6b54418f89dbde634
sha256sums = 463841cc16059b516cc327cfbc30d3383e2236b085ba2d503e82f5be39444806
sha256sums = 9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923
diff --git a/PKGBUILD b/PKGBUILD
index 0303e69d0979..a0103e20f6de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ DOC_DIRS=(opt/hydrus/help)
pkgbase=hydrus
pkgname=(hydrus)
-pkgver=388
+pkgver=389
pkgrel=1
pkgdesc="Danbooru-like image tagging and searching system for the desktop"
arch=(any)
@@ -22,13 +22,13 @@ optdepends=('ffmpeg: show duration and other information on video thumbnails'
'miniupnpc: automatic port forwarding'
'desktop-file-utils: to add Hydrus to your desktop environment menus'
)
-source=("${pkgbase}::git+https://github.com/hydrusnetwork/${pkgbase}.git#commit=3edc910a965a3bd65fb11c1a7d9c00fd9be7ff6c"
+source=("${pkgbase}::git+https://github.com/hydrusnetwork/${pkgbase}.git#commit=5014c369b173b2a7c5f4ab5d9333b3e93a3fd0c8"
paths-in-opt.patch
hydrus-client
hydrus-server
hydrus.desktop)
sha256sums=('SKIP'
- 'e6c77ba667604cfb2e7d9959e79d3ad05c976dcc6297f25a8fcad730a63d2f11'
+ '6f580d7a4313484fde4b085debe7e9657f01a2d31c4d5202e08ad33701a9d594'
'7b0dbc6f38f9aaff409e435ba807199575166976b52715d6b54418f89dbde634'
'463841cc16059b516cc327cfbc30d3383e2236b085ba2d503e82f5be39444806'
'9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923')
diff --git a/paths-in-opt.patch b/paths-in-opt.patch
index 8b0054631bf7..c76252842e91 100644
--- a/paths-in-opt.patch
+++ b/paths-in-opt.patch
@@ -1,8 +1,8 @@
diff --git a/include/ClientGUI.py b/include/ClientGUI.py
-index b6913b2..e23ef1b 100755
+index 87a1213..ce62212 100755
--- a/include/ClientGUI.py
+++ b/include/ClientGUI.py
-@@ -738,7 +738,7 @@ class FrameGUI( ClientGUITopLevelWindows.MainFrameThatResizes ):
+@@ -740,7 +740,7 @@ class FrameGUI( ClientGUITopLevelWindows.MainFrameThatResizes ):
python_executable = python_executable.replace( 'pythonw', 'python' )
@@ -12,46 +12,44 @@ index b6913b2..e23ef1b 100755
cmd = [ python_executable, server_script_path, db_param ]
diff --git a/include/HydrusConstants.py b/include/HydrusConstants.py
-index 3969396..bd6651a 100755
+index 5b0aa75..10b528c 100755
--- a/include/HydrusConstants.py
+++ b/include/HydrusConstants.py
-@@ -2,33 +2,9 @@ import os
- import sys
+@@ -4,31 +4,8 @@ import sys
+ # old method of getting frozen dir, doesn't work for symlinks looks like:
+ # BASE_DIR = getattr( sys, '_MEIPASS', None )
- # dirs
-+RUNNING_FROM_FROZEN_BUILD = False
-
--if getattr( sys, 'frozen', False ):
+-RUNNING_FROM_FROZEN_BUILD = getattr( sys, 'frozen', False )
+-
+-if RUNNING_FROM_FROZEN_BUILD:
-
-- RUNNING_FROM_FROZEN_BUILD = True
+- real_exe_path = os.path.realpath( sys.executable )
-
-- # we are in a pyinstaller frozen app
+- BASE_DIR = os.path.dirname( real_exe_path )
-
-- BASE_DIR = getattr( sys, '_MEIPASS', None )
+-else:
-
-- if BASE_DIR is None:
+- try:
-
-- raise Exception( 'It seems this hydrus is running from a frozen bundle, but there was no _MEIPASS variable under sys to define the bundle directory.' )
+- hc_realpath_dir = os.path.dirname( os.path.realpath( __file__ ) )
+-
+- BASE_DIR = os.path.split( hc_realpath_dir )[0]
+-
+- except NameError: # if __file__ is not defined due to some weird OS
+-
+- BASE_DIR = os.path.realpath( sys.path[0] )
-
--
--else:
--
-- # maybe this is better?
-- # os.path.dirname( __file__ )
--
-- RUNNING_FROM_FROZEN_BUILD = False
--
-- BASE_DIR = sys.path[0]
-
- if BASE_DIR == '':
-
- BASE_DIR = os.getcwd()
-
++RUNNING_FROM_FROZEN_BUILD = False
+BASE_DIR = os.path.expanduser("~/.local/share/hydrus")
PLATFORM_WINDOWS = False
PLATFORM_MACOS = False
-@@ -41,23 +17,16 @@ elif sys.platform == 'linux': PLATFORM_LINUX = True
+@@ -41,23 +18,16 @@ elif sys.platform == 'linux': PLATFORM_LINUX = True
RUNNING_FROM_SOURCE = sys.argv[0].endswith( '.py' ) or sys.argv[0].endswith( '.pyw' )
RUNNING_FROM_MACOS_APP = os.path.exists( os.path.join( BASE_DIR, 'running_from_app' ) )