summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--paths-in-opt.patch13
3 files changed, 17 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b4fadbc0215..a343ee56244d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hydrus
pkgdesc = Danbooru-like image tagging and searching system for the desktop
pkgver = 390.b
- pkgrel = 1
+ pkgrel = 2
url = http://hydrusnetwork.github.io/hydrus/
install = hydrus.install
arch = any
@@ -39,7 +39,7 @@ pkgbase = hydrus
source = hydrus-server
source = hydrus.desktop
sha256sums = SKIP
- sha256sums = ea26711bb5d4ea1c769727ae8e4e1f2d2b4cd9cb130fb90d392ee7f0b8a85028
+ sha256sums = c6802327827cf77acefa8cdff1b9b45097e4754349ef187d94695f4095ef34dd
sha256sums = 7b0dbc6f38f9aaff409e435ba807199575166976b52715d6b54418f89dbde634
sha256sums = 463841cc16059b516cc327cfbc30d3383e2236b085ba2d503e82f5be39444806
sha256sums = 9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923
diff --git a/PKGBUILD b/PKGBUILD
index efef147e558b..b13c5a28518f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ DOC_DIRS=(opt/hydrus/help)
pkgbase=hydrus
pkgname=(hydrus)
pkgver=390.b
-pkgrel=1
+pkgrel=2
pkgdesc="Danbooru-like image tagging and searching system for the desktop"
arch=(any)
license=(WTFPL)
@@ -28,7 +28,7 @@ source=("${pkgbase}::git+https://github.com/hydrusnetwork/${pkgbase}.git#commit=
hydrus-server
hydrus.desktop)
sha256sums=('SKIP'
- 'ea26711bb5d4ea1c769727ae8e4e1f2d2b4cd9cb130fb90d392ee7f0b8a85028'
+ 'c6802327827cf77acefa8cdff1b9b45097e4754349ef187d94695f4095ef34dd'
'7b0dbc6f38f9aaff409e435ba807199575166976b52715d6b54418f89dbde634'
'463841cc16059b516cc327cfbc30d3383e2236b085ba2d503e82f5be39444806'
'9b8c2603a8040ae80152ff9a718ad3e8803fdc3029a939e3c0e932ea35ded923')
diff --git a/paths-in-opt.patch b/paths-in-opt.patch
index 0d98948a6acd..7e4136096802 100644
--- a/paths-in-opt.patch
+++ b/paths-in-opt.patch
@@ -11,6 +11,19 @@ index 7cec25b..b4e24e5 100644
cmd = [ python_executable, server_script_path, db_param ]
+diff --git a/hydrus/ClientGUIStyle.py b/hydrus/ClientGUIStyle.py
+index 63510b1..b5fc2f6 100644
+--- a/hydrus/ClientGUIStyle.py
++++ b/hydrus/ClientGUIStyle.py
+@@ -4,7 +4,7 @@ from . import HydrusExceptions
+ import os
+ from qtpy import QtWidgets as QW
+
+-STYLESHEET_DIR = os.path.join( HC.BASE_DIR, 'static', 'qss' )
++STYLESHEET_DIR = os.path.join( HC.STATIC_DIR, 'qss' )
+
+ DEFAULT_HYDRUS_STYLESHEET = ''
+ ORIGINAL_STYLE_NAME = None
diff --git a/hydrus/HydrusConstants.py b/hydrus/HydrusConstants.py
index a8684e2..717b3cc 100644
--- a/hydrus/HydrusConstants.py