summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD3
-rw-r--r--hydrus.install3
3 files changed, 5 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d62c6a5f2387..13a8aa1ba647 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -26,6 +26,7 @@ pkgbase = hydrus
depends = python2-send2trash
optdepends = ffmpeg: show duration and other information on video thumbnails
optdepends = miniupnpc: automatic port forwarding
+ optdepends = desktop-file-utils: to add Hydrus to your desktop environment menus
options = !strip
source = hydrus::git+https://github.com/hydrusnetwork/hydrus.git#commit=a61df3303cf69a613fbfe43bf4ba78d172a1c676
source = paths-in-opt.patch
diff --git a/PKGBUILD b/PKGBUILD
index 1630c236211b..f0d0fe237a32 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,7 +24,8 @@ depends=(python2 wxpython opencv python2-beautifulsoup4 python2-yaml
python2-psutil python2-send2trash)
makedepends=(git)
optdepends=('ffmpeg: show duration and other information on video thumbnails'
- 'miniupnpc: automatic port forwarding')
+ 'miniupnpc: automatic port forwarding'
+ 'desktop-file-utils: to add Hydrus to your desktop environment menus')
source=("${pkgname}::git+https://github.com/hydrusnetwork/${pkgname}.git#commit=a61df3303cf69a613fbfe43bf4ba78d172a1c676"
paths-in-opt.patch
running-the-server.patch
diff --git a/hydrus.install b/hydrus.install
index e111ef946053..27c282a04440 100644
--- a/hydrus.install
+++ b/hydrus.install
@@ -1,5 +1,6 @@
post_install() {
- update-desktop-database -q
+ # Ignore failures because it's only an opt dep
+ update-desktop-database -q 2>/dev/null || :
}
post_upgrade() {