summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD122
-rw-r--r--hyper.desktop (renamed from Hyper.desktop)0
3 files changed, 70 insertions, 77 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6121b71fbc57..8b9695264de1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,22 @@
pkgbase = hyper
pkgdesc = A terminal built on web technologies
- pkgver = 3.0.1
+ pkgver = 3.4.1
pkgrel = 1
url = https://hyper.is/
- arch = any
+ arch = x86_64
license = MIT
- makedepends = npm
makedepends = yarn
- makedepends = python2
- depends = nodejs
- depends = electron
- depends = gconf
+ makedepends = npm
+ depends = alsa-lib
+ depends = electron20
+ depends = gtk3
+ depends = libxss
+ depends = nss
conflicts = hyperterm
replaces = hyperterm
- source = https://github.com/zeit/hyper/archive/3.0.1.tar.gz
- source = https://raw.githubusercontent.com/zeit/art/master/hyper/mark/Hyper-Mark-120@3x.png
- source = Hyper.desktop
- md5sums = 5039922cadeb24f7bd6b59693da4c929
- md5sums = f3481e14cba331160339b3b5ab78872b
- md5sums = 74cb7ba38e37332aa8300e4b6ba9c61c
+ source = hyper-3.4.1.tar.gz::https://github.com/vercel/hyper/archive/v3.4.1.tar.gz
+ source = hyper.desktop
+ b2sums = 2c480fbd2162f77bfa3b3f5702a50cfb4fb7d88d133c1b916937233b8556ed2c289ab15fb166615dfcd9859a8919dd24423ed751145ae33fdc29f1c072b5b37e
+ b2sums = 3e204a5417c0c0b5d0de4b25013657e4f27ec951c4c23ad9c5bf661890bcf6e6b7f81454373c5740fc424c6af022a45e6b7f204dffb67afa678cf098c545b590
pkgname = hyper
diff --git a/PKGBUILD b/PKGBUILD
index 9c9b977e14a5..5ee35c97aba5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,90 +1,84 @@
-# Maintainer: Aaron Abbott <aabmass@gmail.com>
-# Contributer: fleischie
-# Contributer: auk
-# Contributer: blind
+# Maintainer: éclairevoyant
+# Contributor: Constantine Fedotov <zenflak@gmail.com>
+# Contributor: aureolebigben <aureolebigben@gmail.com>
+# Contributor: fleischie
+# Contributor: auk
+# Contributor: blind
pkgname=hyper
-pkgver=3.0.2
+pkgver=3.4.1
pkgrel=1
-epoch=
pkgdesc="A terminal built on web technologies"
-arch=('any')
+arch=('x86_64')
url="https://hyper.is/"
license=('MIT')
-groups=()
-depends=('nodejs' 'electron' 'gconf')
-makedepends=('npm' 'yarn' 'python2')
-checkdepends=()
-optdepends=()
-provides=()
-
+depends=('alsa-lib' 'electron20' 'gtk3' 'libxss' 'nss')
+makedepends=('yarn' 'npm')
conflicts=('hyperterm')
replaces=('hyperterm')
-backup=()
-options=()
-install=
-changelog=
-
-_pkgver_project=${pkgver/\.canary/-canary}
-
-source=(
- "https://github.com/zeit/$pkgname/archive/${_pkgver_project}.tar.gz"
- "https://raw.githubusercontent.com/zeit/art/master/hyper/mark/Hyper-Mark-120@3x.png"
- "Hyper.desktop"
+source=("$pkgname-$pkgver.tar.gz::https://github.com/vercel/$pkgname/archive/v$pkgver.tar.gz"
+ "$pkgname.desktop")
+b2sums=('2c480fbd2162f77bfa3b3f5702a50cfb4fb7d88d133c1b916937233b8556ed2c289ab15fb166615dfcd9859a8919dd24423ed751145ae33fdc29f1c072b5b37e'
+ '3e204a5417c0c0b5d0de4b25013657e4f27ec951c4c23ad9c5bf661890bcf6e6b7f81454373c5740fc424c6af022a45e6b7f204dffb67afa678cf098c545b590')
+
+_electron_file_list=(
+ chrome-sandbox
+ chrome_{1,2}00_percent.pak
+ chrome_crashpad_handler
+ libEGL.so
+ libGLESv2.so
+ libvk_swiftshader.so
+ libvulkan.so.1
)
-noextract=()
-md5sums=('065b64a0a8846b2fb04755a66c418d5a'
- 'f3481e14cba331160339b3b5ab78872b'
- '74cb7ba38e37332aa8300e4b6ba9c61c')
-validpgpkeys=()
prepare() {
- cd "$pkgname-$_pkgver_project"
+ cd $pkgname-$pkgver
+
+ # delete husky install from postinstall
+ sed -i 's/\ \&\& husky install//g' package.json
- # yarn is a build-dep according to the README
- yarn install
+ yarn install
}
build() {
- cd "$pkgname-$_pkgver_project"
+ cd $pkgname-$pkgver
- # This build command is the same as the one defined in package.json via
- # npm run dist except that it doesn't build for debian, rpm, etc. and
- # doesn't require some other dependencies
+ # This build command is the same as the one defined in package.json via
+ # npm run dist except that it doesn't build for debian, rpm, etc. and
+ # doesn't require some other dependencies
- # add node_modules binaries to PATH
- oldpath=$PATH
- PATH=$(pwd)/node_modules/.bin:$PATH
+ # add node_modules binaries to PATH
+ oldpath="$PATH"
+ PATH="$(pwd)/node_modules/.bin:$PATH"
- npm run build &&
- cross-env BABEL_ENV=production babel \
- --out-file app/renderer/bundle.js \
- --no-comments \
- --minified app/renderer/bundle.js &&
- command build --linux --dir # need to use command because the
- # function name is build
+ yarn run build &&
+ cross-env BABEL_ENV=production babel target/renderer/bundle.js \
+ --out-file target/renderer/bundle.js \
+ --no-comments \
+ --minified target/renderer/bundle.js &&
+ electron-builder --linux --dir
- PATH=$oldpath
+ PATH="$oldpath"
+
+ # clean up bundled electron files
+ for i in ${_electron_file_list[@]}; do
+ rm dist/linux-unpacked/$i
+ done
}
package() {
- cd "$pkgname-$_pkgver_project"
-
- _appdir="/usr/lib/$pkgname"
- _libinstall="${pkgdir}${_appdir}"
-
- mkdir -p "$pkgdir/usr/bin" "$_libinstall"
- cp -R dist/linux-unpacked/* "$_libinstall"
+ install -Dm644 $pkgname.desktop -t "$pkgdir/usr/share/applications/"
- # link the binary to /usr/bin
- cd $pkgdir/usr/bin
- ln -s "../lib/$pkgname/hyper" hyper
+ cd $pkgname-$pkgver
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm644 app/static/icon.png "$pkgdir/usr/share/pixmaps/$pkgname.png"
- # # TODO: remove included electron libs and use the system ones by symlink
- # cd "$_libinstall"
- # rm libnode.so libffmpeg.so
- # ln -s /usr/share/electron/lib{node,ffmpeg}.so .
+ install -dm755 "$pkgdir/usr/lib/$pkgname/"
+ cp -R dist/linux-unpacked/* "$pkgdir/usr/lib/$pkgname/"
+ for i in ${_electron_file_list[@]}; do
+ ln -s /usr/lib/electron/$i "$pkgdir/usr/lib/$pkgname/"
+ done
- install -Dm644 "$srcdir/Hyper.desktop" "$pkgdir/usr/share/applications/Hyper.desktop"
- install -Dm644 "$srcdir/Hyper-Mark-120@3x.png" "$pkgdir/usr/share/pixmaps/hyper.png"
+ install -dm755 "$pkgdir/usr/bin/"
+ ln -s /usr/lib/$pkgname/$pkgname "$pkgdir/usr/bin/$pkgname"
}
diff --git a/Hyper.desktop b/hyper.desktop
index e07a4bdcd553..e07a4bdcd553 100644
--- a/Hyper.desktop
+++ b/hyper.desktop