summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
-rw-r--r--autohide-menu.patch12
3 files changed, 30 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b4a524f69173..c4f4110ec2fb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Aug 31 04:26:39 UTC 2016
+# Mon Sep 12 15:41:11 UTC 2016
pkgbase = hyperterm
pkgdesc = A terminal emulator built with JS/HTML/CSS on electron
pkgver = 0.7.1
- pkgrel = 3
+ pkgrel = 4
url = https://hyperterm.org/
arch = any
license = MIT
@@ -11,8 +11,10 @@ pkgbase = hyperterm
makedepends = python2
depends = nodejs
depends = electron
- source = https://github.com/zeit/hyperterm/archive/v0.7.1.tar.gz
+ source = https://github.com/zeit/hyperterm/archive/0.7.1.tar.gz
+ source = autohide-menu.patch
md5sums = f06827cbae82f13237cc20dfd0ee170d
+ md5sums = f5ca4b1eed8199186edfed94dd137dbc
pkgname = hyperterm
diff --git a/PKGBUILD b/PKGBUILD
index 53347773bb6e..49c69c6cbff6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Aaron Abbott <aabmass@gmail.com>
+# Contributer: fleischie
pkgname=hyperterm
pkgver=0.7.1
-pkgrel=3
+pkgrel=4
epoch=
pkgdesc="A terminal emulator built with JS/HTML/CSS on electron"
arch=('any')
@@ -19,13 +20,22 @@ backup=()
options=()
install=
changelog=
-source=("https://github.com/zeit/$pkgname/archive/v${pkgver}.tar.gz")
+source=(
+ "https://github.com/zeit/$pkgname/archive/${pkgver}.tar.gz"
+ "autohide-menu.patch"
+)
noextract=()
-md5sums=('f06827cbae82f13237cc20dfd0ee170d')
+md5sums=('f06827cbae82f13237cc20dfd0ee170d'
+ 'f5ca4b1eed8199186edfed94dd137dbc')
validpgpkeys=()
prepare() {
cd "$pkgname-$pkgver"
+
+ # this patch temporarily "fixes" https://github.com/zeit/hyperterm/issues/158
+ # thanks @fleischie
+ patch -p1 < ../autohide-menu.patch
+
npm install
}
diff --git a/autohide-menu.patch b/autohide-menu.patch
new file mode 100644
index 000000000000..dd48670ae9dd
--- /dev/null
+++ b/autohide-menu.patch
@@ -0,0 +1,12 @@
+diff -aur package.pristine/app/index.js package.new/app/index.js
+--- package.pristine/app/index.js 2016-07-26 20:35:30.000000000 +0200
++++ package.new/app/index.js 2016-09-12 15:23:14.737276532 +0200
+@@ -56,7 +56,8 @@
+ icon: resolve(__dirname, 'static/icon.png'),
+ // we only want to show when the prompt
+ // is ready for user input
+- show: process.env.HYPERTERM_DEBUG || isDev
++ show: process.env.HYPERTERM_DEBUG || isDev,
++ autoHideMenuBar: true
+ };
+ const browserOptions = plugins.getDecoratedBrowserOptions(browserDefaults);