summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ffee5920b71a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = hyperdex
+ pkgdesc = HyperDex is a scalable, searchable key-value store
+ pkgver = 1.8.1
+ pkgrel = 1
+ url = http://hyperdex.org
+ arch = x86_64
+ arch = i686
+ license = BSD
+ makedepends = wget
+ makedepends = gcc
+ depends = google-glog
+ depends = popt
+ depends = libpo6
+ depends = libe
+ depends = busybee
+ depends = hyperleveldb
+ depends = replicant
+ depends = libtreadstone
+ depends = libmacaroons
+ source = http://hyperdex.org/src/hyperdex-1.8.1.tar.gz
+ md5sums = a529bb7d1d2e1115805362409d544174
+
+pkgname = hyperdex
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3f1864bb0ec4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c0956bd4e34
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Mobius Horizons <codemobius@gmail.com>
+pkgname=hyperdex
+pkgver=1.8.1
+pkgrel=1
+pkgdesc="HyperDex is a scalable, searchable key-value store"
+url="http://hyperdex.org"
+arch=('x86_64' 'i686')
+license=('BSD')
+depends=('google-glog' 'popt' 'libpo6' 'libe' 'busybee' 'hyperleveldb' 'replicant' 'libtreadstone' 'libmacaroons')
+makedepends=('wget' 'gcc')
+conflicts=()
+replaces=()
+backup=()
+source=("http://hyperdex.org/src/${pkgname}-${pkgver}.tar.gz")
+md5sums=('a529bb7d1d2e1115805362409d544174')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
+
+# vim:set ts=2 sw=2 et: