summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD13
2 files changed, 7 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c5d0a4715ad..57045e23b946 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hyperion
pkgdesc = An opensource 'AmbiLight' implementation
pkgver = 1.03.2
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/hyperion-project/hyperion.ng
arch = i686
arch = x86_64
@@ -10,22 +10,12 @@ pkgbase = hyperion
arch = armv7h
arch = aarch64
license = MIT
- makedepends = avahi
makedepends = cmake
- makedepends = git
- makedepends = qt5-serialport
depends = libusb
- depends = python
depends = protobuf
+ depends = python
depends = qt5-base
optdepends = xorg-server: X11 grabbing
- provides = hyperion
- conflicts = hyperion-git
- conflicts = hyperion-rbp
- conflicts = hyperion-rbp-git
- conflicts = hyperion-rbp-bin
- conflicts = hyperion-ng-rbp
- conflicts = hyperion-ng
backup = etc/hyperion/hyperion.config.json
source = https://github.com/tvdzwan/hyperion/archive/1.03.2.tar.gz
sha512sums = 7406f5bdf323d2799fb375557603fefd1f077cda287b5aa9ff10251b22d8dd07590458515b0e01ef97fba80885aab1aa72bd8b5d26873ad8ebcc1ba53d6776ec
diff --git a/PKGBUILD b/PKGBUILD
index a5c21f2f1b24..9df051b9b0f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,14 @@
pkgname=hyperion
pkgver=1.03.2
-pkgrel=3
+pkgrel=4
pkgdesc="An opensource 'AmbiLight' implementation"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/hyperion-project/hyperion.ng"
license=('MIT')
-depends=('libusb' 'python' 'protobuf' 'qt5-base')
+depends=('libusb' 'protobuf' 'python' 'qt5-base')
optdepends=('xorg-server: X11 grabbing')
-makedepends=('avahi' 'cmake' 'git' 'qt5-serialport')
-provides=('hyperion')
-conflicts=('hyperion-git' 'hyperion-rbp' 'hyperion-rbp-git' 'hyperion-rbp-bin'
- 'hyperion-ng-rbp' 'hyperion-ng')
+makedepends=('cmake')
backup=('etc/hyperion/hyperion.config.json')
source=("https://github.com/tvdzwan/${pkgname}/archive/${pkgver}.tar.gz")
sha512sums=('7406f5bdf323d2799fb375557603fefd1f077cda287b5aa9ff10251b22d8dd07590458515b0e01ef97fba80885aab1aa72bd8b5d26873ad8ebcc1ba53d6776ec')
@@ -25,9 +22,9 @@ build() {
cmake -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr" \
-DCMAKE_BUILD_TYPE=Release \
-DENABLE_QT5=ON \
- -DUSE_SHARED_AVAHI_LIBS=ON \
- -DUSE_SYSTEM_PROTO_LIBS=ON \
+ -DPLATFORM=x86 \
-DPROTOBUF_PROTOC_EXECUTABLE=/usr/bin/protoc \
+ -DUSE_SYSTEM_PROTO_LIBS=ON \
..
make
}