summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO47
-rw-r--r--PKGBUILD42
-rw-r--r--hyperstake-git.desktop12
-rw-r--r--hyperstake-git.install11
4 files changed, 112 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..57c2bb7004b0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,47 @@
+# Generated by mksrcinfo v8
+# Mon Dec 21 05:11:07 UTC 2015
+pkgbase = hyperstake-git
+ pkgdesc = Peer-to-peer network based digital currency (QT)
+ pkgver = 20151221
+ pkgrel = 1
+ url = https://bitcointalk.org/index.php?topic=678849.0
+ install = hyperstake-git.install
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = pkg-config
+ makedepends = git
+ makedepends = boost-libs
+ makedepends = boost
+ makedepends = gcc
+ makedepends = qrencode
+ makedepends = make
+ makedepends = automoc4
+ makedepends = automake
+ makedepends = autoconf
+ makedepends = libtool
+ depends = qt4
+ depends = gcc-libs
+ depends = miniupnpc
+ depends = openssl
+ depends = db
+ depends = protobuf
+ provides = hyperstake
+ provides = hyperstake-qt
+ provides = hyperstaked
+ provides = hyperstake-bin
+ provides = hyperstake-daemon
+ conflicts = hyperstake
+ conflicts = hyperstake-qt
+ conflicts = hyperstaked
+ conflicts = hyperstake-bin
+ conflicts = hyperstake-daemon
+ source = hyperstake::git+https://github.com/hyperstake/HyperStake.git
+ source = hyperstake-git.desktop
+ source = hyperstake-git.install
+ sha256sums = SKIP
+ sha256sums = a061fa16c9380787b4617bdf988605aa2d9c250125dcc7a8e570e211cc89be96
+ sha256sums = ebf7090ca1202e2c2ccd1aa5bb03e6ac911c458141a1cedda9b41f9c26c2602c
+
+pkgname = hyperstake-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dce6227bd27b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Onishin <onishin at onishin.org>
+
+pkgname=hyperstake-git
+_gitname=hyperstake
+pkgver=20151221
+pkgrel=1
+pkgdesc="Peer-to-peer network based digital currency (QT)"
+arch=('i686' 'x86_64')
+url="https://bitcointalk.org/index.php?topic=678849.0"
+license=('MIT')
+
+depends=('qt4' 'gcc-libs' 'miniupnpc' 'openssl' 'db' 'protobuf')
+makedepends=('pkg-config' 'git' 'boost-libs' 'boost' 'gcc' 'qrencode' 'make' 'automoc4' 'automake' 'autoconf' 'libtool')
+provides=('hyperstake' 'hyperstake-qt' 'hyperstaked' 'hyperstake-bin' 'hyperstake-daemon')
+conflicts=('hyperstake' 'hyperstake-qt' 'hyperstaked' 'hyperstake-bin' 'hyperstake-daemon')
+install=hyperstake-git.install
+source=("$_gitname::git+https://github.com/hyperstake/HyperStake.git"
+ "$pkgname.desktop"
+ "$pkgname.install"
+)
+
+sha256sums=('SKIP'
+ 'a061fa16c9380787b4617bdf988605aa2d9c250125dcc7a8e570e211cc89be96'
+ 'ebf7090ca1202e2c2ccd1aa5bb03e6ac911c458141a1cedda9b41f9c26c2602c')
+
+
+build() {
+ cd "$srcdir/hyperstake"
+ ./autogen.sh
+ ./configure --with-incompatible-bdb
+ make || make || make
+}
+
+
+package() {
+ install -Dm644 hyperstake-git.desktop "$pkgdir"/usr/share/applications/hyperstake.desktop
+ cd "$srcdir/hyperstake"
+ install -Dm755 src/qt/hyperstake-qt "$pkgdir"/usr/bin/hyperstake-qt
+ install -Dm644 src/qt/res/icons/hyperstake-128.png "$pkgdir"/usr/share/pixmaps/hyperstake128.png
+}
+
+
diff --git a/hyperstake-git.desktop b/hyperstake-git.desktop
new file mode 100644
index 000000000000..ca96675ecd15
--- /dev/null
+++ b/hyperstake-git.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Hyperstake
+Comment=Hyperstake P2P Cryptocurrency
+Comment[fr]=Hyperstake, monnaie virtuelle cryptographique pair à pair
+Comment[tr]=Hyperstake, eşten eşe kriptografik sanal para birimi
+Exec=/usr/bin/hyperstake-qt
+Terminal=false
+Type=Application
+Icon=/usr/share/pixmaps/hyperstake128.png
+MimeType=x-scheme-handler/hyperstake;
+Categories=Office;
diff --git a/hyperstake-git.install b/hyperstake-git.install
new file mode 100644
index 000000000000..f98ba7338938
--- /dev/null
+++ b/hyperstake-git.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}