summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD34
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e9311b68b5d7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = hyphen-cs
+ pkgdesc = Czech hyphenation rules
+ pkgver = 20061030
+ pkgrel = 1
+ url = http://ooo.mirror.dkm.cz/pub/openoffice/contrib/dictionaries/
+ arch = any
+ license = GPL2
+ optdepends = hyphen: offers hyphenation library functions
+ source = http://ooo.mirror.dkm.cz/pub/openoffice/contrib/dictionaries/hyph_cs_CZ.zip
+ md5sums = 7dc7192fb3c141db6518c54781df6846
+
+pkgname = hyphen-cs
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a6b5e5e85edd
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+*.pkg.tar.xz
+*.pkg.tar.xz.sig
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b57319943112
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Jakub Klinkovský <kuba.klinkovsky@gmail.com>
+
+pkgname="hyphen-cs"
+pkgdesc="Czech hyphenation rules"
+pkgver=20061030
+pkgrel=1
+arch=("any")
+optdepends=("hyphen: offers hyphenation library functions")
+url="http://ooo.mirror.dkm.cz/pub/openoffice/contrib/dictionaries/"
+license=("GPL2")
+source=(${url}hyph_cs_CZ.zip)
+md5sums=('7dc7192fb3c141db6518c54781df6846')
+
+build() {
+ /bin/true
+}
+
+package() {
+ cd "$srcdir"
+ install -dm755 ${pkgdir}/usr/share/hyphen
+ install -m644 hyph_cs_CZ.dic ${pkgdir}/usr/share/hyphen
+
+ # the symlinks
+ install -dm755 ${pkgdir}/usr/share/myspell/dicts
+ pushd ${pkgdir}/usr/share/myspell/dicts
+ for file in ${pkgdir}/usr/share/hyphen/*; do
+ ln -sv /usr/share/hyphen/$(basename $file) .
+ done
+ popd
+
+ # docs
+ install -dm755 ${pkgdir}/usr/share/doc/$pkgname
+ install -m644 README_hyph_cs_CZ.txt ${pkgdir}/usr/share/doc/$pkgname
+}