summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD20
2 files changed, 14 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2dbb5bb2f947..e9fda89500b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = hyphen-ru
pkgdesc = Russian hyphenation rules
- pkgver = 20200604
- pkgrel = 1
- url = https://cgit.freedesktop.org/libreoffice/dictionaries/tree/ru_RU
+ pkgver = 20210727
+ pkgrel = 2
+ url = https://github.com/LibreOffice/dictionaries/tree/master/ru_RU
arch = any
license = custom
depends = hyphen
- source = hyphen-ru.dic::https://cgit.freedesktop.org/libreoffice/dictionaries/plain/ru_RU/hyph_ru_RU.dic?id=12e591abdbc5565e5018ed9b8fbe6d635ade87d7
- source = hyphen-ru-README.txt::https://cgit.freedesktop.org/libreoffice/dictionaries/plain/ru_RU/README_ru_RU.txt?id=12e591abdbc5565e5018ed9b8fbe6d635ade87d7
+ source = hyphen-ru-30dd499.dic::https://github.com/LibreOffice/dictionaries/raw/30dd499/ru_RU/hyph_ru_RU.dic
+ source = hyphen-ru-30dd499-README.txt::https://github.com/LibreOffice/dictionaries/raw/30dd499/ru_RU/README_ru_RU.txt
sha256sums = e9a6ae92765fc7e63d879f2ccf3f50f2b95bc8ed7618a6f31c34ce7d39844c83
sha256sums = 262af2f6ad70a61e5ee1332ff44fa8ee50edca819cf33207d8ad6ba6a0c9be52
pkgname = hyphen-ru
-
diff --git a/PKGBUILD b/PKGBUILD
index 3d0cef47ac76..6113df4b87b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,23 @@
# Maintainer: Dmytro Meleshko <dmytro.meleshko@gmail.com>
pkgname=hyphen-ru
-pkgver=20200604
-_commit=12e591abdbc5565e5018ed9b8fbe6d635ade87d7
-pkgrel=1
+pkgver=20210727
+_commit=30dd499
+pkgrel=2
pkgdesc="Russian hyphenation rules"
arch=('any')
-url='https://cgit.freedesktop.org/libreoffice/dictionaries/tree/ru_RU'
+url='https://github.com/LibreOffice/dictionaries/tree/master/ru_RU'
license=('custom')
depends=('hyphen')
-source=("${pkgname}.dic::https://cgit.freedesktop.org/libreoffice/dictionaries/plain/ru_RU/hyph_ru_RU.dic?id=${_commit}"
- "${pkgname}-README.txt::https://cgit.freedesktop.org/libreoffice/dictionaries/plain/ru_RU/README_ru_RU.txt?id=${_commit}")
+source=("${pkgname}-${_commit}.dic::https://github.com/LibreOffice/dictionaries/raw/${_commit}/ru_RU/hyph_ru_RU.dic"
+ "${pkgname}-${_commit}-README.txt::https://github.com/LibreOffice/dictionaries/raw/${_commit}/ru_RU/README_ru_RU.txt")
sha256sums=('e9a6ae92765fc7e63d879f2ccf3f50f2b95bc8ed7618a6f31c34ce7d39844c83'
'262af2f6ad70a61e5ee1332ff44fa8ee50edca819cf33207d8ad6ba6a0c9be52')
package() {
cd "$srcdir"
- install -Dm644 "${pkgname}-README.txt" "${pkgdir}/usr/share/licenses/${pkgname}/README.txt"
+ install -Dm644 "${pkgname}-${_commit}-README.txt" "${pkgdir}/usr/share/licenses/${pkgname}/README.txt"
install -dm755 "${pkgdir}/usr/share/hyphen"
install -dm755 "${pkgdir}/usr/share/myspell/dicts"
- for dict in "${pkgname}.dic"; do
- install -Dm644 "${dict}" "${pkgdir}/usr/share/hyphen"
- ln -sT "/usr/share/hyphen/${dict}" "${pkgdir}/usr/share/myspell/dicts/${dict}"
- done
+ install -Dm644 "${pkgname}-${_commit}.dic" "${pkgdir}/usr/share/hyphen/hyph_ru_RU.dic"
+ ln -sT "/usr/share/hyphen/hyph_ru_RU.dic" "${pkgdir}/usr/share/myspell/dicts/hyph_ru_RU.dic"
}