summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 25 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c753efdc9fd0..2dbb5bb2f947 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = hyphen-ru
pkgdesc = Russian hyphenation rules
- pkgver = 0.1
- pkgrel = 3
- url = http://wiki.services.openoffice.org/wiki/Dictionaries
+ pkgver = 20200604
+ pkgrel = 1
+ url = https://cgit.freedesktop.org/libreoffice/dictionaries/tree/ru_RU
arch = any
- license = LGPL
- optdepends = hyphen: offers hyphenation library functions
- source = https://master.dl.sourceforge.net/project/openofficeorg.mirror/contrib/dictionaries/hyph_ru_RU.zip
- sha256sums = 95b2198f937f1ba1fe2373302c81517ee88a38c237a1ed5557c543a7e2b141df
+ license = custom
+ depends = hyphen
+ source = hyphen-ru.dic::https://cgit.freedesktop.org/libreoffice/dictionaries/plain/ru_RU/hyph_ru_RU.dic?id=12e591abdbc5565e5018ed9b8fbe6d635ade87d7
+ source = hyphen-ru-README.txt::https://cgit.freedesktop.org/libreoffice/dictionaries/plain/ru_RU/README_ru_RU.txt?id=12e591abdbc5565e5018ed9b8fbe6d635ade87d7
+ sha256sums = e9a6ae92765fc7e63d879f2ccf3f50f2b95bc8ed7618a6f31c34ce7d39844c83
+ sha256sums = 262af2f6ad70a61e5ee1332ff44fa8ee50edca819cf33207d8ad6ba6a0c9be52
pkgname = hyphen-ru
diff --git a/PKGBUILD b/PKGBUILD
index 58d1f50eaed8..3d0cef47ac76 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,25 @@
# Maintainer: Dmytro Meleshko <dmytro.meleshko@gmail.com>
pkgname=hyphen-ru
-pkgver=0.1
-pkgrel=3
+pkgver=20200604
+_commit=12e591abdbc5565e5018ed9b8fbe6d635ade87d7
+pkgrel=1
pkgdesc="Russian hyphenation rules"
arch=('any')
-url="http://wiki.services.openoffice.org/wiki/Dictionaries"
-license=('LGPL')
-optdepends=('hyphen: offers hyphenation library functions')
-source=(#http://ftp.services.openoffice.org/pub/OpenOffice.org/contrib/dictionaries/hyph_ru_RU.zip
-# mirror from ApacheOpenOffice - see: http://www.openoffice.org/distribution/mirrors/master.html
-# http://sunsite.informatik.rwth-aachen.de/ftp/pub/mirror/OpenOffice/contrib/dictionaries/hyph_ru_RU.zip
-https://master.dl.sourceforge.net/project/openofficeorg.mirror/contrib/dictionaries/hyph_ru_RU.zip)
-sha256sums=('95b2198f937f1ba1fe2373302c81517ee88a38c237a1ed5557c543a7e2b141df')
+url='https://cgit.freedesktop.org/libreoffice/dictionaries/tree/ru_RU'
+license=('custom')
+depends=('hyphen')
+source=("${pkgname}.dic::https://cgit.freedesktop.org/libreoffice/dictionaries/plain/ru_RU/hyph_ru_RU.dic?id=${_commit}"
+ "${pkgname}-README.txt::https://cgit.freedesktop.org/libreoffice/dictionaries/plain/ru_RU/README_ru_RU.txt?id=${_commit}")
+sha256sums=('e9a6ae92765fc7e63d879f2ccf3f50f2b95bc8ed7618a6f31c34ce7d39844c83'
+ '262af2f6ad70a61e5ee1332ff44fa8ee50edca819cf33207d8ad6ba6a0c9be52')
package() {
cd "$srcdir"
- install -vdm755 "$pkgdir/usr/share/"{hyphen,myspell/dicts,"doc/$pkgname"}
- for dict in hyph_ru_RU.dic; do
- install -vm644 "$dict" "$pkgdir/usr/share/hyphen"
- ln -sv "/usr/share/hyphen/$dict" "$pkgdir/usr/share/myspell/dicts"
+ install -Dm644 "${pkgname}-README.txt" "${pkgdir}/usr/share/licenses/${pkgname}/README.txt"
+ install -dm755 "${pkgdir}/usr/share/hyphen"
+ install -dm755 "${pkgdir}/usr/share/myspell/dicts"
+ for dict in "${pkgname}.dic"; do
+ install -Dm644 "${dict}" "${pkgdir}/usr/share/hyphen"
+ ln -sT "/usr/share/hyphen/${dict}" "${pkgdir}/usr/share/myspell/dicts/${dict}"
done
- install -vm644 README_hyph_ru_RU.txt "$pkgdir/usr/share/doc/$pkgname"
}