summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD26
2 files changed, 14 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 58af84526bcc..542ea6d18e61 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hyprland-nosystemd-git
pkgdesc = A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks. (w/o systemd)
- pkgver = 0.34.0.r95.cf1886ca
+ pkgver = 0.40.0.r144.a60c7283
pkgrel = 1
url = https://github.com/hyprwm/Hyprland
arch = x86_64
@@ -16,10 +16,14 @@ pkgbase = hyprland-nosystemd-git
makedepends = pkgconf
makedepends = xorgproto
depends = cairo
+ depends = cpio
depends = gcc-libs
depends = glib2
depends = glibc
depends = glslang
+ depends = hyprlang
+ depends = hyprcursor
+ depends = hyprwayland-scanner
depends = libdisplay-info
depends = libdrm
depends = libglvnd
@@ -50,10 +54,10 @@ pkgbase = hyprland-nosystemd-git
depends = xorg-xinput
depends = xorg-xwayland
depends = libdisplay-info.so
- provides = hyprland=0.34.0
+ provides = hyprland=0.40.0
conflicts = hyprland
source = hyprland-nosystemd-git::git+https://github.com/hyprwm/Hyprland.git
- source = git+https://gitlab.freedesktop.org/wlroots/wlroots.git
+ source = git+https://github.com/hyprwm/wlroots-hyprland.git
source = git+https://github.com/hyprwm/hyprland-protocols.git
source = git+https://github.com/canihavesomecoffee/udis86.git
source = git+https://github.com/wolfpld/tracy.git
diff --git a/PKGBUILD b/PKGBUILD
index bf0277fcee95..81cda05300c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Modified based on hyprland-nvidia-nosystemd-git
pkgname=hyprland-nosystemd-git
-pkgver=0.39.0.r12.g79a139c9
+pkgver=0.40.0.r144.a60c7283
pkgrel=1
pkgdesc="A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks. (w/o systemd)"
arch=(x86_64 aarch64)
@@ -17,6 +17,7 @@ depends=(
glslang
hyprlang
hyprcursor
+ hyprwayland-scanner
libdisplay-info
libdrm
libglvnd
@@ -79,15 +80,6 @@ pick_mr() {
git pull origin pull/$1/head --no-edit
}
-pkgver() {
- cd "$srcdir/$pkgname"
- if git describe --long --tags >/dev/null 2>&1; then
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
- else
- printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git describe --always)"
- fi
-}
-
prepare() {
cd hyprland-nosystemd-git
git submodule init
@@ -98,9 +90,13 @@ prepare() {
git -c protocol.file.allow=always submodule update
git -C subprojects/wlroots-hyprland reset --hard
- sed -E -i -e "s/(soversion = .*$)/soversion = 13032/g" subprojects/wlroots-hyprland/meson.build
}
+pkgver() {
+ git -C hyprland-nosystemd-git describe --long --tags | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g'
+}
+
+
build() {
cd hyprland-nosystemd-git
@@ -126,15 +122,7 @@ package() {
--destdir "$pkgdir" \
--skip-subprojects hyprland-protocols
- mkdir -p "$pkgdir/usr/include/hyprland/wlroots"
- mv "$pkgdir/usr/include/wlr" "$pkgdir/usr/include/hyprland/wlroots"
-
- # resolve conflicts with system wlr
- rm -f "$pkgdir/usr/lib/libwlroots.so"
- rm -rf "$pkgdir/usr/lib/pkgconfig"
-
# FIXME: remove after xdg-desktop-portal-hyprland disowns hyprland-portals.conf
-
rm -rf "$pkgdir/usr/share/xdg-desktop-portal"
# license