summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 72e965927c4b..de340097db1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,21 @@
-# Maintainer: Guillaume Duboc <guilduboc@gmail.com>
+# Maintainer: Boris-Chengbiao Zhou <bobo1239@web.de>
+# Contributor: Guillaume Duboc <guilduboc@gmail.com>
pkgname=hyx
-pkgver=2020.06.09
+pkgver=2020.12.24
pkgrel=1
pkgdesc='A minimalistic, but powerful console hex editor'
url='https://yx7.cc/code/'
license=('MIT')
depends=('glibc')
source=("https://yx7.cc/code/hyx/hyx-${pkgver}.tar.xz")
-sha512sums=("c2a0fb3b37f1589a9a810dafbc2fa3ea85ee41b988c7a8a9e3f577eb3f4b959a5516a7d059d46b1f5bb5127b2aed6381f7759f9185dfbcbb4489192ffc73e767")
+sha512sums=("a1b84fc7b4f566424292fb03b8b8bf25fe0c3cd5342efeb0894b29856394cc8350f2c3f749649e6ca345c7bf3a24ac331ba276070301102a27cd6b067daec35b")
arch=('i686' 'x86_64')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
+ # Pass $LDFLAGS via $CFLAGS since hyx's Makefile only considers $CFLAGS
+ export CFLAGS="$CFLAGS $LDFLAGS"
make
}
@@ -21,4 +24,3 @@ package() {
install -Dm755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
install -Dm644 'license.txt' "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-