summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xPKGBUILD13
-rwxr-xr-xwrapper.config38
2 files changed, 31 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c1209e9d07a9..463e8aad7f00 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: skydrome <skydrome@protonmail.com>
pkgname=i2p-bin
-pkgver=0.9.42
+pkgver=0.9.43
pkgrel=1
pkgdesc="A distributed anonymous network (pre-compiled binary)"
url="https://geti2p.net"
@@ -17,22 +17,23 @@ install='i2p.install'
noextract=("i2pinstall_${pkgver}.jar")
options=(!strip)
+# https://geti2p.net/en/get-involved/develop/release-signing-key
+# https://geti2p.net/_static/zzz.key.asc
+validpgpkeys=('2D3D2D03910C6504C1210C65EE60C0C8EE7256A8')
+
#_url="https://download.i2p2.de/releases/${pkgver}"
_url="https://launchpad.net/i2p/trunk/${pkgver}/+download"
source=("${_url}/i2pinstall_${pkgver}.jar"{,.sig}
'i2prouter.service' 'i2prouter.sh' 'wrapper.config' 'router.config')
-sha256sums=('cb192e48c5f06839c99b71861364f3a9117b6b24f78f7f7c25d6716507c81bdf'
+sha256sums=('e5eb3db08dcc594e2fb01ada63303ff48096a454db1c7659c928ddb07736c84a'
'SKIP'
'9bb899ece87099716da29bac8b7da02916fc325699b68989e73c1fe333a6342f'
'ea8f97e66461d591b1819eab39bbc40056b89ae12f7729b3dd9fd2ce088e5e53'
- 'da8da9e30edb19fa276be37716b9e59061b1b5ef6b505c8c7c132f1c2b29d4b4'
+ '5d134ee5bc614b54ec48de7c5214f6dbe08abcfab7d286c5b1c7616e39b478ed'
'1527afbadcf849ef551b3b7b68d1a29eec316ee620f5320f2933f73ee9924978')
-# https://geti2p.net/en/get-involved/develop/release-signing-key
-validpgpkeys=('2D3D2D03910C6504C1210C65EE60C0C8EE7256A8')
-
package() {
source /etc/profile.d/jre.sh
echo "INSTALL_PATH=${pkgdir}/opt/i2p" >install.properties
diff --git a/wrapper.config b/wrapper.config
index b09517bf5bb0..0df169c9020a 100755
--- a/wrapper.config
+++ b/wrapper.config
@@ -4,17 +4,15 @@
#
# WARNING - for any changes to take effect, you must completely
# stop the router and the wrapper. Clicking 'Restart' on your
-# router console will NOT reread this file! You must
-# click "Shutdown", wait 11 minutes, then start i2p.
+# router console will NOT reload this file! You must
+# click "Shutdown", wait 10 minutes, then start i2p.
#
#********************************************************************
# Java Application
wrapper.java.command=/usr/lib/jvm/default/bin/java
# Java Main class. This class must implement the WrapperListener interface
-# or guarantee that the WrapperManager class is initialized. Helper
-# classes are provided to do this for you. See the Integration section
-# of the documentation for details.
+# or guarantee that the WrapperManager class is initialized.
wrapper.java.mainclass=org.tanukisoftware.wrapper.WrapperSimpleApp
# Java Classpath (include wrapper.jar) Add class path elements as
@@ -44,8 +42,8 @@ wrapper.java.additional.4.stripquotes=TRUE
# Two things that may help if you experience this issue
# 1) "echo 0 > /proc/sys/net/ipv6/bindv6only" as root; or
# 2) uncomment the next two lines:
-wrapper.java.additional.5=-Djava.net.preferIPv4Stack=true
-wrapper.java.additional.6=-Djava.net.preferIPv6Addresses=false
+#wrapper.java.additional.5=-Djava.net.preferIPv4Stack=true
+#wrapper.java.additional.6=-Djava.net.preferIPv6Addresses=false
# Location used to hold temporary files.
wrapper.java.additional.7=-Djava.io.tmpdir=/opt/i2p/.tmp
@@ -75,6 +73,7 @@ wrapper.app.parameter.1=net.i2p.router.Router
wrapper.console.format=PM
# Log Level for console output. (See docs for log levels)
+# https://wrapper.tanukisoftware.com/doc/english/prop-console-loglevel.html
wrapper.console.loglevel=INFO
# Log file to use for wrapper output logging.
@@ -129,16 +128,12 @@ wrapper.jvm_exit.timeout=60
# give the OS 60s to clear all the old sockets / etc before restarting
# Let's change the default from 60 to 10 seconds and see if anyone moans..
wrapper.restart.delay=5
+wrapper.restart.reload_configuration=TRUE
-wrapper.ping.interval=300
# The ping timeout must be at least 5 seconds longer than the value of wrapper.ping.interval.
# Extend this if you are getting 'JVM appears hung' shutdowns.
wrapper.ping.timeout=320
-
-# use the wrapper's internal timer thread. otherwise this would
-# force a restart of the router during daylight savings time as well
-# as any time that the OS clock changes
-wrapper.use_system_time=false
+wrapper.ping.interval=300
# pid file for the JVM
# If you plan to have multiple wrappers running on the same machine,
@@ -155,7 +150,7 @@ wrapper.java.pidfile=/run/i2p/i2p.pid
wrapper.ignore_sequence_gaps=TRUE
# Title to use when running as a console
-wrapper.console.title=I2P Service
+wrapper.console.title=I2P Router Service
# Set permissions used when creating files
# See http://wrapper.tanukisoftware.com/doc/english/prop-umask.html
@@ -163,3 +158,18 @@ wrapper.console.title=I2P Service
wrapper.umask=0022
wrapper.java.umask=0022
wrapper.logfile.umask=077
+
+#********************************************************************
+# Wrapper JVM Checks
+#********************************************************************
+# Out Of Memory detection.
+wrapper.filter.trigger.1=java.lang.OutOfMemoryError
+wrapper.filter.action.1=RESTART
+wrapper.filter.message.1=The JVM has run out of memory.
+
+#********************************************************************
+# Advanced Options
+#********************************************************************
+# Enable the Shenandoah Gargabe Collector
+#wrapper.java.additional.100=-XX:+UnlockExperimentalVMOptions
+#wrapper.java.additional.101=-XX:+UseShenandoahGC